Blueprint Crash when Launching to Device "class is not mapped when saving"

I have a Blueprint base-class that is nativized using the checkmark on Class Settings.
I then create a sub-class of that BP and do not think to check the value for the Nativize setting.
Subsequent “Launch” to (in my case Quest) result in sporadic crashes of the editor with an error containing the following output:

Assertion failed: !Export.ClassIndex.IsNull() [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/CoreUObject/Private/UObject/SavePackage.cpp] [Line: 4957] Export SKEL_BP_Subclass_C /Game/Customer/BP/BP_Subclass.Default__SKEL_BP_Subclass_C class is not mapped when saving /Game/Customer/BP/BP_Subclass

Note The value for this checkbox is stored in DefaultEngine.ini; not on the Blueprint asset itself. (If you’re using version control make sure to submit Config.)

Update (2020-01-30) As of this morning this “fix” is no longer an effective cure for the problem. (Life comes at you fast.)

I just ran into the same crash today

I ran into this problem when i added a bone to my vr pawn hand. The game will launch once then crash next time i launch, after crash n restart i just launch again. works but annoying.

2 Likes

I’m having the same issue and cannot figure out what the problem is, just like in the OP output. My engine also crashes with a messge about SKEL_* of my player character.

Anyone solved this? I’ve been digging around and this seems to be the only thread on this topic.