Blueprint could not be loaded

Blueprint could not be loaded because it derives from an invalid class. Check to make sure the parent class for this blueprint hasn’t been removed!

ok thats the error i got, this is because i couldn’t compile my project to update the module so i created a new basic code project with the same name as the old one and then copied the content over including the blueprints. i take it between my project and the latest build things have changed again so that the blueprint parent class is no longer there.
fine as this was just a basic blueprint based in the character class, but i can’t even edit the blueprint properties to change the parent to point to the new character class.

now i can see all sorts of problems coming from this if the code base for any project gets changed then you’ll lose access to the blueprints that are parented to the changed class

Unfortunately, that’s a non-recoverable error. Since we record the parent class for the blueprint, if that parent cannot be found (it’s not stored by name, it’s an actual class reference), we have no idea where it came from. It’s just null.

We could allow you to open the blueprint, but there’d be a lot of gaps and holes, and would probably lead to more confusion. The best way to deal with these when migrating between projects is to keep the old version around somewhere, and then reparent it before moving it to something that is global, like Actor, and then attempt to open it in the new location.

ok thanks Nick, i’ll keep that in mind for the future, i’m sure it will crop up

I made the projectile example from Alan Thorn’s C++ tutorial on the Rocket forum. It worked, but next time I launched Rocket with the sameproject and tried to open the projectile I’d saved it says: “Blueprint could not be loaded because it derives from an invalid class. Check to make sure the parent class for this blueprint hasn’t been removed!”

If I rerun Debug from VisualStudio I can open the projectile blueprint just fine.
Then when I save Rocket and the VIsualStudio project and close, relaunching makes the same message come up.

It sounds like you maybe are launching Rocket with an out of date code module. Did you build the shipping config of your module before launching Rocket outside of VS?

sorry mate i can’t help as i still don’t have access to beta 5

Hi George,

I believe you have Beta 5 access now. If you are still experiencing a problem, please let us know.


Dear Tom,

Make sure the editor is running the same version of your game that VS is compiling

you can either

  1. change your rocket shortcut by adding -debug at the end
  2. in VS change your build to Development, which is the default build that the rocket editor shortcut uses.

I explain this with pictures in step 2 of my ue4 forum c++ tutorial

This may be a stupid question but I’m new to C++ and BPs. How do you re-parent a class for a newly imported BP? I’m receiving the same error message as in the description. Is there a simple way to reparent a series of BP’s that are freshly imported into a new project?

Hi Kalibur,

As this is here for archival purposes only and is from our beta build of UE4, please use the Answer Hub to ask this question. Thank you!