Blueprint AI Move To aborted

I looked all over the internet and here, but I could not find what I am missing.
I am trying to create a simple AI that patrols between two target points. I am trying to do this in Blueprint with AI Move To node.

I have this simple 2D Paper Character with empty, default AI Controller. I have navmesh that fits the level.

I am unable to understand why is the action aborted.
I tried debugging the blueprint and it only gives me this information

It shows (unknown) till the end of the trace.

Can anyone help me see what I’m missing?

I’m sorry if this is really obvious, but have you placed a navmesh?

Second screenshot shows the navmesh.

I tried using Move to Location with the target point’s location and disabled ‘Use Pathfinding’. Moved the logic from the character to the AI controller and made it that from Begin Play on character, to set target points of AI Controller so the AI controller knows where to move the character. It worked. But the moment I turn on ‘Use Pathfinding’ even while inside the NAV mesh, it still aborts…
I am convinced that this is not the most viable solution, but for now - it works as good as I need it to.

Ok, what about event ticks with bools? So,

get distance to [target point]
if distance = 0
set at location_1 true
branch if @ location_1 true
ai move to [target_point_2]
if false
ai move to [target_point]

Sorry if this makes minimal sense, I do not have Unreal installed on the desktop I am currently using, and as such cannot create an example ¯_(ツ)_/¯