Download

Blueprint Actor , added a Hierarchical Instanced static mesh component. LODs not working

added a Hierarchical Instanced static mesh component. I dont see my LOD changing when I zoom out or when I Change Lit to HLcoloration. I thought that when we add a HISM component
in a blueprint actor and that Actor has LOD’s on it that it will switch through the different levels of lod depending on screen size(cam distance)…I switch my views from Lit to Hierarchical LOD Coloration as well as Mesh LOD coloration and all my models dissapear. Acting as if I dont have Lods on them. I check by grabbing the model from content and placing it directly in the scene and
I can see the different colorations as I zoom out so I know that the LOD work, just not the Models with lods that are HISM instances within a blueprint actor…Maybe im wrong maybe this never worked…just odd that it wouldnt work just because the model is inside a blueprint.

so i made a separate project and created a blueprint actor with **Hierarchical Instanced static mesh component and created instances and used a model with a lod and it works fine…just something about my other project that the models with lods dont show up. **

I created a separated project. I migrated out one of my blueprints from the other project into the new project and the BP act just fine. I can see the LOD when in the MESH LOD COLORATION mode…getting closer but its getting more weird.

anyone have a idea what would make a project not show Mesh LOD Coloration models from BluePrint Actors HISM that have LODs on them? Theres got to be something in the Project setting or World setting or something. Because this is happening in all my levels within the project.

so I can see the models lod switching… which is great. Its just for some reason that particular view mode isnt working correctly in this project. anyway I guess its all goood.