Blue screen win10 everytime I close my project

everytime I close my project I get a blue screen and my computer restarts.

the error is “Reference by pointers”.

I can privately submit my project if you need it for debugging purpose.

Hello ,

Does this only occur with your particular project or does this also happen with fresh projects? If it is only your project, is the logic through blueprint or code? If it is project specific, it would be very helpful if you could send it to me through a private message on the forums.

Here is a link to my profile:

100% blueprints.

I had this problem on 4.9 version too and this version is the same 4.9 project after changing the engine target to 4.10.

this doesn’t happen with fresh project.

message in your private inbox :slight_smile:

Unfortunately, no luck getting the blue screen to occur on my PC. Can you upload the dxdiag for your machine? Also, please check this list of Known Software Conflicts to see if there may be anything listed there that is causing issues.!113954&authkey=!AHvYSaZiyMwa8JM&ithint=file%2Ctxt

I always close with the X button (not by clicking file → exit) and the crash do not happen like 100% of the times.

what I usually do is:

  1. open p4v client and click get latest
  2. open the project from the .project file (this will also start the launcher)
  3. close the launcher
  4. choose “don’t detect changes on startup” and connect it to the source control workspace
  5. do my stuff, save, submit (from the editor)
  6. close the project when I’m done (by clicking the X window key)
  7. delete every folder except config and content, it, upload a backup.

(perforce is in a local server, that’s the reason for the daily backup, I don’t know how to perform a clean backup with perforce server)

a few seconds after the step 6 sometimes it gives me a blue screen and restart the pc

Thank you for the information. Is there anything you do after opening the project before closing it that may be causing this to occur? I’ve tried playing in the editor, closing it immediately, opening a few blueprints but no Windows crash yet.

Unfortunately no luck getting the crash with those steps either. I do have something for you to try though for us to narrow it down. Can you follow the steps in this guide to get some more information about the windows crash?

Please upload any event logs you can get from this method.

In win 10 I can’t see any “Application Error” but I do have some critical error: “The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.”

and by looking at the datetime I can see some events in “Windows Log” => “Applications” just before each critical error.

I saved these errors here if you wanna take a loot:!114016&authkey=!ADlj-EM2OO5Uby4&ithint=file%2Cevtx


Hm, unfortunately that doesn’t tell me much. You mentioned that the blue screen that you receive mentions “Reference by Pointers”. Is there an error code that appears as well? If so, could you get that written down? Seeing as the screen doesn’t stay up for long, it may be best to use a camera / cellphone to take a picture when it happens.

Also, can you try updating to the latest version of Windows 10? Looking at your version from your dxdiag it seems like yours could still be the beta version from shortly before the official release which could be causing some issues.

Lastly, are you attempting to use DX12 with the editor by chance? If so, try disabling that and see if the issue persists.

I’m not using dx12 and I will try to update windows thanks.
I will try to make a screenshot of the error.

In the last week it never happened again, but 1 week ago I had multiple blue screen during the same day (around 90% of the times).

I will let you know if maybe windows update will solve things out, thanks

We haven’t heard from you in a while, . Have you had the windows crash occur lately? If so, please let me know the details we previously spoke about whenever you have a chance. In the meantime, I’ll be marking this as resolved for tracking purposes.

hey! it never crashed again so I guess it is solved but I havent really used ue4 that much lately so idk. I would let you know if something happen again. thank you

sadly the problem occured again, 3 times in the last 2 days and with different projects (the content example and other free projects).

I don’t know if it can help but I always had VLC opened and p4v client too while working on ue4. I couldn’t make the screenshot in time but I can send you other logs if you need them…

Any logs you could send would be helpful. I’ll still yet to get the crash to happen on my end as of yet. I’ll continue researching and let you know if there are any updates.