Blockout Tools Plugin

Hey, that’s nice! I need to think about it some time later (being very busy with Sky Creator recently). Sorry for a late answer.

1 Like


Hello. Can you tell why blockout tools has this weird lighting bug? “Cast shadow” unchecked solves the thing, but I’d like to check the project properly with shadows on.

Hello. It’s the Distance Field Ambient Occlusion on these meshes. Usually it doesn’t play nice with such primitive geometry really, it’s a known thing. You can disable shadows on SkyLight and it should fix it for the time being.
At first I disabled any DF features on blockout meshes, but then someone asked me to get them back to be able to use DF Shadows, so here we are :slight_smile:

1 Like

Got it. Thank you!

Hello …How to Static Mesh in UE5 with this tools ?
I trying to u r documention and test that. But not ok . Migrate is Default blockout to making .plesase help me . If u have time , i request to making SM video tuto. Thanks you

Hello!
Huh… I guess they moved the option from the RMB menu. So right now it’s located in Actor Menu in editor right there.

1 Like

Ohh… Thanks alot.I solved with anthoer way. That is using modeling mode and selected to Block-out and Create >> MeshMrg that make to new static mesh. haha thanks thanks . I can used to 2 ways.

I seem to be getting this error in UE5 while packaging, another person experiences the same thing on the market page.

Module.BlockoutToolsPlugin.cpp.obj : error LNK2011: precompiled object not linked in; image may not run.

I’m not entirely sure, but maybe your compile toolchain isn’t up to date. Maybe need to update Windows SDK or VS runtime libraries… Just a suggestion for the time being.

I am able to build just fine in my IDE, but packaging specifically is where the error happens. Another weird thing is that I am able to package my projects just fine in another empty project. So this is likely an error from trying to upgrade a UE4 project to a UE5 project. I’m using Visual Studio 2019 14.29.30141 toolchain.

I finally found the issue. It happens when you generate an encryption key in the project settings. I have no idea why, but it causes this error to happen with your plugin. So to replicate:

  1. Generate encryption key in project settings. Edit: Then click on all the Encrypt file options, there should be 4 of them.
  2. Package project for windows. You should get the same error, if not, then also generate a signing key and enable pak signing, then package again, you should be getting the error now.

Edit: It gets even stranger, clearing the encryption key on a new third person template while still having the plugin enabled allows you to package the game again, but on my original project, the moment I use the plugin, encryption key or not, it still causes the issue. I even tried regenerating files and deleting binaries, etc. Hope you can figure this out!

1 Like

Hello! Thanks for the info. I’ll try to reproduce it when I can.