Blocking Volumes NOT Blocking Top-Down Camera


I have a problem - I’m trying to stop my camera from running off the edge of the map. It’s a simple top-down camera with a static mesh root - spring arm - camera setup that moves with wasd. I’ve placed some blocking volumes (WorldStatic type) around the edges of the map and made sure the Pawn collision is blocked. I’ve triple checked all the collision settings on my camera and they are all set to Pawn with the WorldStatic set to block.

For some reason when I move my camera it just sails straight through the blockers. Any ideas? Thanks. Screens attached:

The blockers are for characters. Your camera is just a blueprint, it has no character code.

You could re-parent it with the character actor

Oh my lord you just solved my hours-long dilemma in two seconds, thankyou!

1 Like