Blocked on agent job unspecified


I couldn’t make Ureal Engine editor working with the “Build Lighting Only” toolbar’s menu command, because it’s freezing the editor while the Swarm Agent is exporting to local cache. The only way to continue is to manually kill the UE editor process manually and start again, and I did it too many times now.

When I look at the Swarm log, I can see this message being infinitely repeated at regular intervals:

 **[Maintain Jobs] Job is AGENT_JOB_UNSPECIFIED**

I have tried all what is said on the other posts, and what in the unreal engine documentation (Firewall issues, ports, uninstalling and reinstalling everything and reboot, standalone mode, run in admin mode, registry setting of the graphic card, windows update, display adapter update, clean and verify the cache, disk space, disk access, change the cache folder, kill all other processes, fixing the “No connection could be made because the target machine actively refused it 123.456.7.89:8009”, debug break the UE editor’s process but no assembly code is visible at all…).

As I would really love to use Unreal Engine, could anybody please help me?

The Swarm agent is locked on : Exporting to local cache, it never ends, more than 1 hour… I have a fast hexacore computer, with a GTX 1080 adapter.

This is occurring also when I create a new empty project and directly press the build lighting only button.

Thanks in advance for your help.

Please note that I’m using only one local computer, no remotes.

Completely disabling the firewall still gives the same issue.

Allowing file sharing and removing password protection, stills gives the same issue.

Framework .Net 4.6 & 4.6.1 installed…

Hi All,

Nobody has answered, it is working fine now. What I did is uninstalling old unused Unity 3D versions and installed the last one. I also have installed the latest Visual Studio 2019 version and there was a system update that has appeared in between.

The problem seems due to missing files or distribution packages that has been solved by installing other products.

I hope this will help.

Just uninstall Incredibuild. Go to Control Panel → Programs and Features-> select Incredibuild → Uninstall. It solved my problem.