Blendspace crash

I am updating my project from UE4.4.2 to UE4.5.1, and I have a blendspace with two animations. Well, when I try to edit it, by just clicking on one of those two animations little circle, on the graph area, it just crashed the engine.
The screenshot if from UE4.4.2, because UE4.5.1, just crashed again, and I opened the 4.4.2 version to edit the blendspace file there. :wink:

http://s7.postimg.org/vnef385mj/blendspace_Bug.jpg

Thank you for your report. We will begin investigation into this issue as soon as possible. If we are unable to reproduce the problem, or need more information, we will follow up with some additional questions for you. Otherwise, we will post an ‘Answer’ once the issue has been logged in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide:

Thank you.

Hi Alex3d,

I’ve tried to reproduce your issue with a new project started in UE4.5.1 as shown here:

As well as by updating a project from 4.4.3 shown here:

However, neither case resulted in a crash. In order to better evaluate your issue, please provide the following logs:

the “UE4.log” Located: Engine\Saved\Logs\
…and the “ProjectName.log” Located: ProjectName\Saved\Logs\

Thanks

After all crashes, I submited the crash report, using the crashing reporting windows that appear when crashes happens. But, ok, i will collect those and send you.

Only log files that I found: File Dropper - Online file sharing

And here is a video showing the crashing. It happens all the time!

Hi Alex3d,

Thanks for taking the time to send your crash log and provide an animation to illustrate the issue. While not being able to reproduce here, other users have reported a similar issue so we’ve generated a bug report: UE-4691.

Should this issue be addressed in the future, an update will be posted on this thread.

Hi Alex3d,

Thanks for taking the time to send your crash log and provide an animation to illustrate the issue. While not being able to reproduce here, other users have reported a similar issue so we’ve generated a bug report: UE-4691.

Should this issue be addressed in the future, an update will be posted on this thread.

Hi Alex3d,

In order to help troubleshoot this further the developers have requested your call stack as well as the animation assets from the 4.5 converted version of your project.

If you could provide these it would greatly aid in pinpointing the problem.

Thanks.

Hi Steve.

My call stack? kkk I don’t know what you mean. :frowning:

Also, I just tried with a new UE4.5.1 third person BP project, and the editor still crashes, using the default animations and a BlendSpace 1D. So, this is not related to my project.
I added two animations and save it. Then I clicked on the smal animation circle icon, and nothing happened. Then I clicked on the other one. Nothing happened again. Then I clicked on the first one, again, and voilá. Editor crashed!

Hi Alex3d,

Sorry I wasn’t clear on how to obtain your callstack. When you experience a crash there’s a button on the crash screen that says “Copy callstack to clipboard.” If you copy that information and send it in a word doc it helps our developers compare it with other crashes to determine if this is an emerging issue.

I’ve also tried again in UE4.5.1 to reproduce a crash following your instructions. I’ve used idle/walk, idle/run, idle/punch, run/punch… when I click one circle button and then the other along the axis, the slider moves along with the mouse. Is this what you are experiencing? Also what are the two animations you are blending between? I appreciate any additional information you can provide.

Here is the callstack: File Dropper - Online file sharing

And here is a new video, showing a new ThirdPerson BP project. I created a new Blendspace 1D, and add two default animations Jump_loop and Jump_start. ( But this happens with all animations )

Then, I just click on the top circle button, and click on the bottom one, click on top again, and the editor crashes. Sometimes the crashing happens with the first click.

Thanks for providing your callstack as well as the additional video link. I’ve tried to recreate this problem precisely according to your video with no change in results.

Hopefully, the additional information you’ve provided will help the developers isolate why you’re experiencing this issue in which case this post will be updated accordingly.

Hi Alex3d,

Thanks for providing all requested information. With your help this issue has been fixed for a future release of the engine.