Blendspace and TimeRemaining

The jump is divided into three phases, each of which is blendspace, the first phase has transition with TimeRemaining Node it is don’t work. I think TimeRemaining not work with Blendspaces, but how I can determinate end of animation?

Use the Time Remaining (ratio) node instead of Time Remaining. I do the same thing (while using blendspaces) for my jumping system and it’s reliable. Time remaining ratio is 0->1 based, 1 is entire time remaining and 0 is no time remaining.

One very important thing is to make sure it is not set to loop

The default is to loop and it is not exposed as a pin so it’s not immediately obvious. The setting is on the Blendspace node inside of your state.

We also have the Relative Time Remaining and Relative Time Remaining (Ratio) nodes if you plan to swap out animations at any point.

Moving this out of Bug Reports.