Download

Blendshapes Not Being Imported and Being Renamed From Maya

I posted this to answer hub, but haven’t gotten a response, so I’m trying here next, because this is starting to drive me insane.

I was testing out importing Blendshapes and morph targets into Unreal using Mixamo. I download the mixamo rig, with the facial blendshapes, and import it into Unreal. Everything is working fine.

So I take it into maya and start retexturing, reuving, and generally working on the model. But, when I go to bring it back into Unreal, several things go wrong. First, it throws up an error saying that “the following bones are missing from the bind pose:” and proceeds to list all of the bones. (All of the bones still work properly, just mentioning this for completion’s sake), then, I look at the morph targets, and there are only three, and one of them doesn’t even have the right name. Of the three, only the one that has the name “MorphTarget_0” actually works. The other two do nothing.

I tried a number of things, and finally, I even tried just opening a blank Maya file, importing the original (working) file, exporting without making any changes, and still the exact same result. What’s going on here?

Also, just as a side note, using the “reimport” function makes the one working blendshape stop working too. Force Deleting the mesh and dragging and dropping back in will make it work again.

If it didn’t bring in any blendshapes or the blendshapes just didn’t work at all, that would make sense. What I can’t understand is why it is randomly picking three blendshapes, why it decides to rename one of them, and why only one of them actually works.