Download

Blending between last and first animanions in blend spaces

i have multiple blend spaces that dont do the interpolation between the last and the first animation, creating an ugly snaping effect.

For exemple: when i press left ctrl it starts a smooth animation transition from idle prone to moving prone (when i move) the problem is when i stop moving because it doesnt do the interpolation between the last animation and the first one (the idle one) its just snaps back to it.

How can i fix this?

Your state machine blend timing.

Could you show screengrabs of your blendspace setup? Depending on what you’re doing it could be the interpolation time/type of your blendspace or the transition duration in your animation blueprint anim graph.

Im not using state machines due to its limitations on controling jump animations, i cant use anim montages on state machines, and the animations on state machines overwrite those in the character blueprint

hope this is enough, somewhat the speedside is actualy the speed forward (key W) i only need animations in this orientation because the character rotates to key orientation

You should probably look over how to set up character’s jump with state machines.

The limitations are in your knowledge, not in the system everyone has used without issues for over a decade.

Regardless. The play montage node has a blend in/blend out parameter as well.

The problem is not the anim montages, is the transition between last and first animation in the blendspaces, they snap between last to first they dont do the interpolation, but they do between first to last

In a blendspace each animation has its own blend time and blend mode you can choose from.
Try something other than linear.

We still have absolutely no idea what it is you are even attempting to do being that you didn’t really explain it, and you are not doing what everyone else has done always for a jump.

Further, you say “jump” and then show us a running 1d blend space (Which is actually also likely incorrect for the simple fact it does not appear to be 1d when it really probably should be.)

If you want help or a solution, maybe try to actually detail your issue enough for people to help…
Screenshots, or videos of the issue happening would probably help.
But are also completely useless without your setup if you aren’t going by standards.

1 Like

Forget about the jump, i just talked about it to tell you that i have a jump sistem that doesnt work properly with state machines (because of anim montages). The main question is the about the last to first animation interpolation

But nevermind, thanks to your comment i figured out, the problem was the interpolation time and type, i should have known this and i thought i already had checked it, turns out i was doing it in the wrong blendspace i must have been tired and didnt notice that. Thank you for the help :slight_smile:

1 Like