Download

Blender + Unreal = Crash

I’m here again saying that it’s impossible to have a Blender + Unreal workflow. The Crashes are random and this makes everything unreliable.

I import a static mesh = Good, no crash.

Import a Mesh with a Armature = 50% Succsess Rate, it’s totally random and makes no sense. Export with 6.1 or 7.4 is all the same. Crash is eminent.

I create a Character with an Armature and I try to import it, it crashes, I create another Character with an Armature that is IDENTICAL to the other one, works like a charm. I move that character to another Blend file, no longer works, crashes. Crashes everywhere.

It’s not my models, I can assure you. I do everything by the book withouth any mistake or problem. But no matter what, Crashes and frustration is all I get from Unreal.

At this stage I’m considering changing to Unity, which has yet to cause any issues to me. I prefer Unreal over Unity because of it’s Features and what it can do, but if I can’t even import anything into it, then it thus in fact make this a terrible engine for me.

Is anyone here using Blender? And have you found a solution to this? Because I’m all out of ideas as this seems to be utterly random lacking any logic behind it.

Sorry to hear you’re having trouble and while I’m not in the anim. phase just yet ( close), just wondering:

You say you did get a successful char. import, what about that one is different in any way ?

They can’t be identical I wouldn’t think.

Can you share them, if so I"d be happy to try it here or adapt it for public use if that helps.

I use blender, but atm barely as I can’t navigate around edit mode due to viewport perf. problems, BUT I imagine what you have would be just fine.

I’m eager for 2.8x so edit mode woes are gone and I can actually edit meshes :wink:

Let me know.

What version of the engine?. 4.14 had import issues, even with Max, but I think in 4.14.1 it’s supposed to be fixed, though I haven’t specifically tested my old exports that crashed, I have been able to import an animation, and I couldn’t before, at all, with just 4.14.

I’m using the latest one. 4.14.1

And the models really are identical, they are simple characters that is easy to replicate the result.

Did you try with 4.13? Crashes started with 4.14 and was no exclusive Blender issue. Even C4D exports crashed at import. I think it had something to do with (missing?) materials but I’m not sure. If 4.13 works you could easy migrate for now … and post a bugreport on answerhub (as a program should not crash, whatever you feed him).

Just tried on 4.13. Samething. As soon as it hits 75% it stop loading and crahes a few seconds later. Everytime independent of version. And I do have Materials correctly assigned. I made sure of it.

Usually I’m using this settings for Blender: https://forums.unrealengine.com/showthread.php?98896-New-project-released-by-MakeHuman-team-leader&p=632353&viewfull=1#post632353
I’m using Blender and UE4 since UE 4.7 without issues and exported/imported meshes hundrets of times (static and skeletal meshes). The only time when I remember a crash was at a buddy that exported that mesh from C4D and tried the same mesh after import/export from Blender at 4.14. If it is crashing then it’s a bug in UE4 and should be reported at answerhub. Even if you feed him some “empty.txt” the editor should just tell you that it does not like that (and if it’s nice even the reason) but should not crash.

Okay, I feel like an Idiot now. I have always been trying to import everything together to save time but apparently that causes issues. But by importing the mesh, the armature, materials, textures, etc all separate caused no crashes at all with all my files that crashed non-stop at 75%!!

Thanks for the help Neutronux, if it weren’t for those pictures you showed me to make me think from a different perspective, I would still be banging my head here. Thanks mate!