Blender -> UE4 Skeletal mesh problem report

Hey all,

So, as requested in the livestream, I’m posting the problem I had with the Blender FBX export & import. Here’s the mesh in Blender:


And, here it is in UE4:


As you can see, some of the verts on the right shoulder are spiking out of control. I’ve checked the bone weights and everything, but it still does this.

Here’s my .blend file: https://www.dropbox/s/v45u4h2v4zd4ela/

If this problem is due to my own stupidity, and not the FBX tools, I apologize. :slight_smile: Although it’s not being caused by any of the usual problems, I’ve checked all of those (I think), so I’m blaming the exporter/importer.

In my case it looks fine :slight_smile: Am I right that you had to rotate your mesh so that it is at the right position in the UE4?

Hmm, that’s strange. What are your export/import settings?

Here’s mine:


(Also, thanks for taking the time to help me out :))

I use the standart import/export settings in blender (of course I have disabled Camera, Lamp and Empty) and the UE4. Basically when I exported/imported it, the mesh was roatet wrong, so I just jumped back into blender, rotated it in the object mode -90 at the x axis -> after that I pressed Object-Apply-Scale (you can find that beside the mode tab).

Now when I import it everything is fine. (in my case I somehow always have to do the upper steps, otherwise it will always be rotated wrong)

Ah, okay…

So if I rotate it like what you did, then uncheck “Use T0 as Ref Pose” in UE4 import, it works. This seems to be a bug then, no? It should work both with or without the T0 thing.

Naw can’t be FBX as it is just a wrapper that stores DCC data and does not add or introduce value changes beyound that.

Spikes in general though are not that unusual and can be casued by a lof of different things.

What is a typical and the most common cause is the rounding off problem.

You have applicaion A) set to three decmial places and you have applicaion B) set to two decmial places the weight is generally round up or down based on the value of the weight so if you have a value weighted to a vertex set to .004, if assigned to a singel joint is still 100%, and brought the mesh into an app set to two places the value becomes .00, which is no weighting at all and will snap to it’s bind pose.

Which brings up an intresting question as to how many decemal places does UE4 support.

you’ll most likely find that the way ward verts have also been weighted to another bone, just select each bone in turn to see which it has been weighted to, just setting the weight in the modifier doesn’t always work, which is why i try to create "empty weight’ groups and then set the weights

I thought so too at first, but the weights are fine, and it still had that problem. And why would turning off “T0 Ref Pose” fix it, if that was the cause?

Spiking Vertices in blender is usually do to improper vertices weighting to the skeleton. Are you should that all the vertices are properly weighted?

Yep, they are. I removed them from all vert groups and reassigned them to the shoulder, didn’t help.

And if they weren’t, disableing T0 Ref Pose wouldn’t have fixed it. :slight_smile:

I know this post has been solved, but since I struggled with this problem myself just now I’ll post what happened to me for extra documentation.

On my mesh there was a single vertex that was misbehaving and spiking after import to UE4. Reskinning, making new vertex etc didn’t help.

This is what solved it for me:
In blender, if you select a single vertex and press N, you get the properties for that vertex and there should be a box there for weight. After selecting the vertex that was “broke” I simply removed the zero weight influences in that box (which was root bone for me) and now it’s all working!