Download

Blender UE4 Animation

Hi im quiet new to 3d design, However I know a little bit.

I have managed to import a .fbx model and the static mesh with bones seems to work fine. I have it importing the right way around and everything. Mesh does not collapse and stands still with no animation.

I then reopend my basic mesh and bones with no animation in blender, Animated an idle pose for my character and saved a new file. I then exported the .fbx file.

However when I came to import it the right arm completely collapses within itself, the animation is running fine, I can see the arm moving how it should. The only problem is its now actually within the body, I cannot figure out how or what is causin this.

Any help would be great thanks. Ive attached some pics.

1.png

2.png

3.png

4.jpg

5.jpg

I am having the same issue with my fps hands. Without animation the mesh is fine, but when I click an animation, ine hand breaks into pieces. Also for some reason positive X in blender becomes negative X on UE. I started having these problems after I uodated blender few weeks back.

Also let me add another thing that is happening. I made a skeletal mesh on blender. Exported fbx. Then I did two animations and exported as skeleton with baked animations. Now I imported everything to unreal. The mesh looks fine, the first animation worked good. The second animation however rotaded my mesh 180 degrees and broke one hand like you said. I didnt turn the mesh 180 in blender when I animated and I didnt mess with export settings. Basically im confused to say the least.

yep, my characters first imported flat on their face, fixed that. Then they started importin 180 degrees out lol, fixed that, And now animated armatures completely collapse the mesh.

Im starting to wonder if it could be the roll rotation of the bones, im goin to try to realign all the z x y axis on the bones then try again.

If blender doesn’t get some support soon im skrewed, cant afford 3ds or maya

When you say fixed, could you tell us how? I love blender but there is always something that goes wrong and its getting to me.

basically for the character on its face, in the unreal mesh advanced settings I ticked : use time 0 pose for ref pose
And the one above it : update ref pose. That then turned them the right way.

For the mesh importin upside down I simply changed the .fbx export settings so that Y is up and X is forward.

That has worked for me so far.

Also I changed blender units to metric with a value of 0.01 so 1 blender unit is the same as 1 unreal unit.
I made the root bone at 0,0,0 - this apparently helps with some of the mesh collapses, However not with mine.
Kept the scale for armature and mesh to 1
also made sure the mesh was at 0,0,0 - for same reason as above.
I heard its best not to scale anything in object mode. And to do all your scale transformations within edit mode.

That’s about all the useful info ive managed to find so far.

And one more thing I forgot. On the root bone if you untick deform in blender that helps too.

Thanks for the info. Ill have to play around with the export axis settings and keep reimporting to ue4 till it is looking the right way. Painful.

There is a huge difference between the way Blender sees bones and the way UE4 sees bones. If you export a character from UE4 in .fbx and open it in Blender you will see what I mean. The rotations are totally different from what you would expect. This shouldn’t cause a problem if you’re using your own animations but if you plan to use the UE4 animations you need to do the export from UE4 and use that skeleton and that skeleton alone. Blender also adds an extra root bone when you export. There used to be an entire thing on YouTube but I can’t find it anymore, but it involves going into Blender’s scripts and commenting out a line of code in the .fbx exporter. Problem is if you don’t do this your skeletons will not work properly in most cases. There is a detailed explanation of all of this here: https://forums.unrealengine.com/showthread.php?28882-Blender-to-UE4-using-UE4-animations&highlight=blender+ue4+animations. Again, if you’re doing your own animations it shouldn’t matter that much but these are some things you should consider when using Blender with UE4 that will make your life much easier.

Yea, apparently when blender exports it adds the main armature as a root bone too. Which then causes unreal to error and mention that it only supports one root bone.

Theres one line of code to comment out, I did that and still no luck unfortunantly. It just gets rid of the error and collapses the mesh the same, And yea im doing all my own animations as I feel I am cheating myself the learning process if I was to do that.

ok it looks like there is quite a few issues here, lets see if I can clear a few up for you all.

first up is units: by default 1 blender unit is the same size as 1 unreal unit witch gives you 2 possible workflows, 1:leave the units in blender at there default (use 1 blender unit as 1CM) and just model to the size you want(you may need to change the cameras clipping distance for when you make big meshes), so if you make a cube that’s 100x100x100 in blender and export with scale of 1 it will bee 100x100x100 units in unreal, 2:change the units in blender to metric with unit scale set to 0.01(like you have), you have to set the unit scale to 0.01 or blender exports 1M at the size of 1 blender unit so it would be 1 unit in UE4 making your mesh tiny. personally I use the first method, its easier/more accurate and the snapping tools work better. you should also create you models at the size you want them to be in engine, I notice your mesh is quite small in both blender and UE4.

next up is orientation: by default UE4 uses X as forward and Z as up, you should do the same (while you could use Y as forward you are creating more work for yourself), I should also say that +Y in UE4 is opposite +Y in blender so if you make your mesh with +Y as forward in blender when you import to UE4 -Y will be forward.

root bone: for your root bone you want to have it as the parent of the hips bone, it needs to be at location 0,0,0 (so where the little dot is in between yours characters feet), and you need to turn on the show bone axis setting and move the tail of the bone around until the bones axis match the axis widget in the bottom left corner of the viewport.

exporting: there are obviously 2 options, to use the old exporter you need to modify it so the extra bone is not added and if you’ve done what I said above you shouldn’t need to change the up/forward settings and then just use the “use TOA ref pose” option during import to UE4 and it should be facing the right direction, you will probably see the bones axis have flipped/switched but as it doesn’t effect the anims it doesn’t matter. to use the newer exporter do the same except you don’t need to modify it although last time I tried it there were a few issues, I would recommend using the old exporter.

as to your problem with the arm there are 2 possible causes that come to mind, 1: a skinning/weighting issue (yours look ok in the pics), 2: a skeleton/bone issue, if its a bone issue try selecting the rig in object mode clear scale/rotation and location and then re-apply them, re-export and give it go.

as a side note you can scale in object mode but you have to be careful, scale the skeleton first (the mesh should scale up with it), apply scale to the skeleton and then select the mesh and apply scale.

I think that covers all of it(might have missed something as I am typing while playing destiny), anyway hope that helps:), oh and if you’ve done everything and have any more issues with the exporters let me know and I’ll post a link to my custom one;)

Figured it out. Definantly a problem with animating the shoulder bones. For some reason it collapses like that. I have no idea what could cause this and I cant see the axis of xyz on the bones to even roll it round the right way, For some reason its rotating from the 3d cursor origin, how can I change it to the top and bottom of the bone?

:: FIXED ::

Downloaded the new blender beta 7.2

opend animation file

exported fbx

set smoothing to faces

ticked only deform bones

select FBX 6.1 ascii

-z forward

Y up

Here are some facts / possibilities / informations:

  • The issue doesn’t happen with the “FBX 6.1 ascii” exporter, like viggerz said (even before Blender 7.2). But it doesn’t solve the problem for many cases because this option doesn’t export shape key animations.
  • The “experimental exporter” addon or the nightly build doesn’t solve the problem, I tried both yesterday.
  • The axis orientation differences between Blender and Unreal is not the problem. If you load the exported FBX file into the “FBX Review” (an Autodesk software) the same problem can be seen there (and the old “FBX 6.1 ascii” works perfectly, like we said before).
  • The issue happens only with unconnected bones.

I’m sorry to answer this old thread, but I have the exact same problem and more people can arrive into this thread using the search, like me. So I added these new informations.

I’m going to check the python script of the exporter, but I don’t think I can fix the problem… I think we actually need to wait for a fix from the Blender team =(.

EDIT:
5 minutes looking at the source code, I found these comments:
“I can’t get this working :(”
“This should work smoothly, but actually is only OK for ‘rest’ pose, actual pose/animations give insane results… :(”
“Bone correction, gives a mess as result. :(”

At least they know exactly where the problem is, I think. I will try to talk with the programmers, maybe they can help me to understand the situation.