Download

BLENDER: Ue to Rigify tool, finger rotation problem

Hi all, first of all, thanks for the plugin. Im having issues, when i create a character (based on MBLab) and make retarget the rig with the tool (in blender 2.83 lts), the fingers dont work as spected when i finish the steps and make convert to rigify.
I send some pictures to show the problem, i was trying to roll the bones, to have the Z axys in the correct place (i think its the problem), but i cant save this changes =(

Thanks in advance!

](filedata/fetch?id=1812356&d=1600310950) the problem

](filedata/fetch?id=1812354&d=1600310950) i think the bones are twisted the, look the Z axis of the metarig and the rig…

but my original (base) armature its well:

](filedata/fetch?id=1812357&d=1600311193)

I would just scale down instead of up.
no sense in messing around with the bone position for something so simple.

i tried , scaling down only one finger act correctly. The others move to the side, look at the first picture. The thumb, the index and other move from side to side or wrong direction. I appreciate help

this is what i mean

To fix the rotations you can either do it manually or use the recalculate bone roll function.
you select the chain all the way up to the metacarpal and using that bone as the active one you recalculate the rolls.

Additionally you can set rigify to lock a specific axis for the finger by editing the metarig super finger properties on the metatacarpal bones. Usually locking to X axis works.

You have to play with the rotations/settings until it works correctly when you build the rig.

Ps:
obviously having both hands work exactly the same allows you to paste opposite. So it is worth doing if you need to do a lot of animations.

Sorry if im wrong. I edit the metarig before making the convert to rigify, also i have bad rotations. With the rigify done, i went to edit mode too, show off the mesh and do roll of the finger joints, lock it up, and nothing, still wrong… i only want to use the driving node to animate fast

Lock has nothing to do with it.
check and copy the rotations from getting a fresh metarig. Add the armature. check the information on the bones - not the transfers but the custom tab that contains the superfinger information, which is in Editpose Mode.

Most likely, the fingers in the meta rig are too straight.
With the default settings Rigify automatically “fixes” the bone roll. This is supposed to aid the user as most people don’t understand bone roll. What it needs is a clear bend in the knuckles. It doesn’t have to be extremely pronounced but it has to be there. Othewise rigify is confused.

The other way to fix this is to go to the the Rig Type options. (Bone tab > Rig Type, only available in Pose Mode). Change Bend rotation axis to a manual setting. Then the bone roll in the meta rig will be respected.

  • but don’t forget to enter edit mode, select all of the finger chain with the metatacarpal as the active, hit space bar and type recalculate bone roll.
    then choose the appropriate option for the correct calc. from active bone.

that will def. Fix the rotation or allow you to invert it…