Blender to unreal issue.

I am exporting suzanne the monkey primitive to unreal with a very simple animation. Yet the animation is microscopic when exported. The mesh is normal size though. Help!

are you scaling during export?, I’ve seen this issue before sometimes being caused by people doing that.

afaik animation needs a rig of some sort, if you have this then you need to scale+reset the rig then animate in blender before you export, if you try scaling on export i don’t think it works, the same goes for scaling on import

I did the traditional scaling at 100x.

I’ve put a rig onto it. I’ve applied the scale.

I’ve had this a lot when first trying to import custom content with animations from Blender.
World scaling doesn’t seem to need to be fiddle with anymore since version 2.74 (no need to set metric).

What I’ve noticed is if I make any scale changes after a the rig was parented and weighted (even if I apply scale to both mesh and rig) I see this tiny mesh once I select the animation in Persona.

What I did after much narrowing down my workflow steps:

  1. create mesh using default blender units 1 BU = 1 Unreal Unit (so I have a character at ~144 blender units tall)
  2. export to UE 4 as static to compare scale (might not be necessary but I wanted to be sure he was going to fit through a door).
  3. rigged the character (ignoring any scale listed in the panel)
  4. animated a quick idle test
  5. brought it all into UE and it worked.

I did notice a glitch when the animation first starts that placed my character’s waist at 0,0,0. At first I thought it was an export issue, but then if you switch windows from the Animation tab to Mesh and then back to Animation, he’s standing on the ground as expected properly scaled and animating.

I’ve since completed a good chunk of basic animations for him and all is well. If I were to go back to step 4 and apply scale to the rig after all of this and export the animation again it would be tiny inside of persona, so I no longer apply scale to the rig.

Yeah, I spent 5 days trying to narrow down this issue, and I have some workarounds, but no answers as to why this happens.

Firstly, I’m assuming that you’re exporting your FBX’s with the version set to: “FBX 7.4 Binary” correct? That’s the source of the scale discrepancy causing the animation to be a different size than the skeletal mesh. It’s a bug I think when using the 7.4 Binary.

I’ve been using that for my project because of the animation bake settings that it has, but it (for what ever reason) rescales ONLY the animation files and not the skeletal mesh or the skeleton (wtf? am I right?). What makes this more confusing is that everything is perfectly fine when you re-import them back into blender.

To avoid this headache, use the “FBX 6.1 ASCII” version setting. Set “Y forward” and “Z up”
It has it’s own quirks that need to be handled in UE4 on import (like disabling “Convert Scene” in the import dialog box), but at least it doesn’t cause this odd rescaled animation problem we get using other FBX versions.

I’ve been ok with FBX binary using my workflow above.
I’m at work so can’t post a screenshot of my export settings, but for the animations I select just armature, Scale set to 1, check in tangent space, uncheck leaf bones, set -Y forward, only have baked animations checked (no NLA strips or All Actions).
On Import in UE4 I uncheck Mesh so that it is only importing the skeletal data. I was also able to import multiple animation files at once without issue.

yeah that’s probably why although as you can see by the other posts there is ways around it, I use 1 blender unit as 1CM the same as psynex, it works for both the exporters and reduces the amount of things that could go wrong.

Have you tried Applying LocRotScale in Blender before rigging? Not doing that caused me no end of grief before I figured it out. Everything was nuts - UV Maps were always twisted, characters were in crazy positions, the whole 9 yards.

Do you mean on the mesh or armature? I attempted apply scale on the armature before rigging, but had the same issue with tiny animations. I hadn’t applied LocRot though.