Download

Blender to unreal 4

Hi guy’s,

I have been busy moddeling in blender for a few weeks now and when I lets say make a plane in blender 100x100 cm and after that i make a other mesh that is a bend it does not fit the mesh and lines are visible how can it be corrected?

Greetings,

I’m not entirely sure what you meant by

Could you clarify that?

Things to check:

  • apply any modifiers (bend) you have to your mesh
  • use ctrl+a and select Rotation & Scale (to apply any transforms you made to your mesh in blender)
  • make sure you are using the right scale when using the .fbx exporter (by default it’s 1.0, but I need to use 100.0 so it’s the correct size in ue4)

I have been working on a road system, the first is just the straight section the second is a bend even if i make the bend in the same origin position as the straight section it does not fit 100% and leaves a tiny gap in between the 2 meshes is I make a road section out of it.

Right now i have it working seamless but there is still a very tiny gap between the meshes (you have to really zoom in a lot to notice) but i was just wondering if there is a better way to make perfectly fitting meshes in blender.

http://s15.postimg.org/lckupqu2f/Capture1.jpg

http://s12.postimg.org/khaysmh8p/Capture22.jpg

Greetings,

I worked with blender for about 2yrs, if you are trying to connect the 2 meshes together so they are one, just merge the vertices. There won’t be a gap. It’ll be one mesh. And as for the lines that pop up, if you do not want them you can delete the lines inside the mesh so all you have are the outlines of the whole one and then just use “fill” to close it up. Make sense?

Yes this makes sense but this is not my problem.

I want to use the plane for a road section so i build it one time in blender and than in unreal editor i copy and paste the mesh to make my road longer when I come to a bend I use my curved mesh.

The problem is that the curved mesh does not fit seamless against the plane mesh when i copy paste the plane mesh forward there is no gap and its seamless but when i come to a curve there is a very small gap.

So basicly i want to make different sections of road that i can use in the editor to create roads.

It is working but when I really zoom in there is a gap when the plane meets the curved section.

Ah, okay. So you have having trouble with your curved mesh.

For a tile-based setup, you need to make sure the vertices of the two (non-curved) edges are in the same locations (relative to the center of the mesh) as they are on the square mesh, so that they meet at precisely the same location without any gap. You can go into edit mode (tab) and adjust the positions of the individual vertices by entering them in manually into the transform panel. Use the n key to toggle the panel on and off (scroll to the top). If your square is 100cm along x and y, then the lower right vertex is going to be at 50cm(x),-50cm(y) relative to the center.The lower right vertex on the curved mesh should have the precise same coordinates, but it is probably off by a little. Just manually enter in the correct coordinates. Check all three of the vertices on the straight edges of the curve mesh.

Also, if the mesh has any thickness to it (not just a plane, more of a box), you need to do that for both the top(z) and bottom(-z) set of vertices.

From that picture it looks like your mesh does has thickness to it, and the vertices of the right hand face are not aligned, and you have a sort of steep slant from the top to the bottom vertices. So you will need to manually set the coordinates for all 4 vertices to flatten out that right hand face and have it exactly where it needs to be.


This won’t help with precision (still need to manually enter coordinates for that) but a quick way to flatten a slanted face like that is to scale the vertices of that face on the axis perpendicular to the face. So in this case scaling all the vertices of the right face on the x axis. Scale it down to 0 and they will all be aligned.

Quick tutorial: First change the viewport shading to wireframe (selection is easiest in wireframe) and drag a box to select all the vertices on that side, and scale (s key) and then lock the axis (x key for x axis in this case, y or z depending on situation) and scale them dragging inward while holding the ctrl key (it enables snapping to even increments). There is a little readout on the bottom of the viewport that will tell you how much you are scaling by, and you want to do it until it says Scale X: 0.000. Very useful for flattening a whole group of vertices when you want.


Just keep in mind when manually inputing vertex coordinates that those coordinates are relative to the mesh’s center/origin. Those coordinates don’t change if you change the object’s scale (distinction between mesh and object). That is what apply transforms is for (ctrl+a). It updates the mesh so the vertex coordinates reflect that new size (relative to the mesh’s center). So if you doubled an object’s scale, and used ctrl+a, now the vertex is twice as far from the mesh center, and the object scale returns to 1 (instead of 2). I mention all this since it’s important to keep in mind when exporting from blender (like fbx) so that things are exported as the size you intended.

I actually made the curved mesh out of the same mesh as the plane i deleted the top and left verts and added a quart circle to complete it but still not same location :frowning:

Creating prefab-style meshes like this is much more complicated than one would think. You have to be careful as you set things up to preserve the same size and dimensions.

The first step is determining what size all the prefabs will be. Like 500x500 or 1000x1000.

I would also suggest changing your origin point on the mesh. For example starting from X0 Y0 Z0 and modelling into the positive values. In real-world blueprinting and manufacturing it’s called a datum point. A point that everything is relative to. Once it’s in UE4 that becomes your pivot point.

In Blender you can also click the + in the top right of the 3D window and there’s a section for directly setting the coordinates of vertices. Toggle the Global button and have at it.

For example:

dkLcziU.jpg

A 2x2 square. Notice the origin point is in the bottom left at X0 Z0, and the selected top right vertice is at X2 Z2.

79dddd349abb80b406377a6feb564039d98e5d02.jpeg

A curved bit. Same origin point, same overall size. The top right is missing, but it would still be X2 Z2.

It’s a lot of tricky work to keep things consistent and in line with all the other pieces. And that’s not even getting into making any textures applied tile properly, which is an entire other can of worms.

Hope it helps.

Hi Guy’s,

Just tested this its just a plain mesh in blender 800 by 800 no thickness to it.
I want to make a road system so you can just hold alt drag and drop in the editor and make 1 straight section and 1 curved section so you can make 90 degree turns.

The problem I have is in the curved and square mesh If I take the square mesh and, copy and paste it directly forward or sideways there is no gap but when I rotate either there is.

I can make 1 straight mesh square with 1 texture for forward and 1 for sideways curved mesh I have to test out how many the problem lies when I start rotating any meshes.

http://s13.postimg.org/7s1kaxodf/Capture1.jpg
http://s22.postimg.org/hyxwonc1p/Capture2.jpg

I tried setting the origin point for the curved mesh on your position Enos and there was no gap in the center when i copy it 3 more times and rotate each 90 degrees to create a cicle out of the 4 meshes but on the outside there is even if its very tiny.

http://s13.postimg.org/4lpea9xgj/Capture.jpg
Here is a screen It is already done out of 2 meshes 1 straight and 1 curved with self made textures my question is it up to standard even if there is such a tiny gap or is it worth making it out of more meshes and perhaps make it 100% seamless.

Greetings,