Download

Blender to UE4

So I think I know what I’m doing wrong at this point I’m just wondering what would be the best way to fix it.

so I have a model with a skeleton in blender, the forward direction in +X
when ever I import to UE4 with force X forward it imports backwards

I noticed in most Epic resources that talk about blender, they have there models forward in the -Y I hadn’t noticed this until after I made the model (also I have a habit of making the +X forward)

any ideas how I can fix this?

you may be overthinking it, I found the defaults work best, meaning make a person in blender facing the default ortho view (I think thats +y). Export to FBX, defaults are -Z forward Y Up. UE import is default. The character now faces the default view in the mesh viewer in UE. I usually clear any rotation or translation in blender since there are ways that can mess things up I think.

I don’t really know what I did to blender but I can use UE4’s default import options to bring in assets oriented correctly. That said, you can always toggle on in the engine settings to show import dialogue on reimport; really helps rapid fire import options, and try flipping around the rotation axis.

I only found out that blender uses the Y axis as default forward, until after I started a habit of using the X axis as forward

Yea. I wish Blender had a more robust export function especially with coordinate systems. I was thinking of using -Y as forward, and Z up at least for this scene.

Thanks for the replys.

Just so you guys understand this, the X and the Z axis in blender and unreal are identical. It is only the Y that is in the opposite direction.

The way you can visualise this is to make a little finger pistol with your hand, with your thumb pointing up and your index finger at 90 degrees to your thumb pointing forward. Then put your middle finger at 90 degrees to both of those. So if you do this finger pistol with your left hand, you have the Unreal coordinate system, so get a Sharpie permanent marker and write a big U in the palm of your left hand. If you do it with your right hand, you have the blender coordinate system, so write a big B in your right hand. So your thumb is pointing in the positive Z direction, your index finger is pointing in the positive X direction and your middle finger is pointing in the positive Y direction. If you do a Tom Cruise double finger pistol, pointing your index fingers forward you can see the problem. Your middle fingers (Y axis) are pointing towards each other. Your thumbs are parallel, your index fingers are parallel, so no issue with X or Z :wink: No matter how you try to rotate your hands you are never going to get these three different axes to line up.

That all being said the advice to just leave it is probably good advice. I always export on the default settings of -Y forward and Z up when really it should be +X forward. It seems to work anyway. I think as long as Z is up, you can always rotate your mesh on the way in, using the Transform > Import rotation part of the FBX Import Options panel.

Just remember that you want your characters, your weapons and your vehicles to all be pointing in the positive X direction and you should be okay.

I have +X as forward for everything that I’ve made in blender but for some reason it isn’t working

I think I remember it working in a older version of UE4 for some reason, but not now

It could be that your import settings are holding onto a rotate value that you may have rotated in the past. Just go fown the import window and make sure it’s cleared at 0,0,0

they’re at 0,0,0. maybe its blender, I tried exporting and re-importing in to blender, when ever I change the forward or up vector, and re import in to blender, there is no change. is this the case for anyone else?

I definitely had problems when starting out with Blender, but eventually you fix it, then save a startup file just in case, and forget the problem ever existed…

I’ll have to boot it up tomorrow and try again with default startup.