Download

Blender to UE4 Smoothing Issue

I’ve been using Blender to prepare meshes to use in UE but I’ve been having an issue with the smoothing groups for some of the meshes when I bring them into UE. When smoothed in Blender, the textures on the meshes develop artifacts. I can alleviate this in Blender with the Edge Split modifier but when I try to export the mesh, the textures have the artifacts again in UE. I’ve been looking around for a solution to this for a while but I haven’t found any useful solutions to it. Has anyone had this issue and found a fix or workaround for it? Any input would be appreciated.

UE:

Blender:

1st try not to use boolian subtraction as this can make a right mess of the mesh surface (triangles)
2nd in the past i’ve used the smooth option on selected faces then on export select the face option for smoothing in the fbx exporter

Also select and make sharp edges at the end of a smooth surface to make the mesh look better.

You should enable Auto Smooth in the object data panel.

So, I tried to mark the sharp edges and export an FBX from Blender using the “Edge” option for smoothing. When there were only a few edges marked, the mesh looked fine in the surrounding area. However when I went to mark more edges as sharp this happened:

ad4f813caa2175110a87847a71225cfc788f1c21.jpeg

Any thoughts

Have you tried applying that edge split modifier? Most of the time it works for me using Face smoothing export option and applying that edge split modifier just before i export.

Do you apply it before you export or do you let the exporter apply it?

Whenever I use the Edge Split modifier, it works in Blender but it seems like the exporter completely ignores it and just applies plain smooth shading. The mesh on the right in the image had Edge Split applied to it right before I exported using Face smoothing.

Hi,
Did you set “import normals and tangent” when importing your mesh in UE4?

I just tried “import normals and tangents” but it didn’t do anything apparent to the mesh. The problem with the broken mesh only seems to occur in the mobile preview, all of the other previews with it look fine. I do get an error for degenerate tangent base when I import the mesh, but I’m not sure if that is an issue or not.

I think I discovered what the issue is. The mobile platform has a limit of 65K verts for meshes, the completely smoothed mesh has less than 65K and the other mesh has much more than 65K verts. Now my question is how to reduce then number of verts in the non-completely smoothed mesh. Any suggestions?

You can try the decimate modifier. Or just retopo it.

For anyone who is curious to know what I ended up doing. I was able split up the mesh into multiple pieces and get the pieces under the 65K vert threshhold with the decimate modifier and with the limited dissolve function. Thanks for the help everyone.