Download

Blender to UE4 problems with bones & Unreal

I got a simple weapon rigged, some bones are connected physically and others no, and after export to UE4 i got this list of problems:

  • The bones now have new bones called _end ??

  • All bones are connected with new bones ?

  • At try to rotate the root bone of the weapon after rotate about 270º only rotate 15º ??

  • Blender 2.74 using FBX 7.4

  • Unreal Engine 4.8 P1 (But in the 4.7 i got the same problems)

Unreal + Import Settings:

https://dl.dropboxusercontent.com/u/28070491/UE/Forums/WeaponUnreal.png

Blender + Export Settings:

https://dl.dropboxusercontent.com/u/28070491/UE/Forums/WeaponBlender.png

in blenders exporter turn off the “add leaf bones” option, I don’t know why they added that option or why they’ve turned it on by default but turning it off will stop those bones being added.

bones and the lines showing their parents are displayed differently in blender and UE4, in blender your bones are shown as sticks with a head and tail - in UE4 bones show as a ball at the bones location, in blender the parenting lines are shown as a dotted line - in UE4 the parenting shows as a stretched pyramid(very similar to how blenders default bones look).

so your bones(except the added “end” bones) and parenting are still the same its just being displayed differently, you’ll be able to see it better once you get rid of the end bones.

hope that helps:)

Thanks you @smokey13 unchecked the “add leaf bones” now the bones are okay.
But the problems on UE4 about rotate the model continue.

Well i find the problem its a problem with the bones scale or something:

[X] A. If export the model from Blender with scale x100 and import to UE4 give this problem.
[X] B. If export from Blender with scale x1 and import with uniform scale of x100 give the same problem.
[V] C. If in Blender copy the project and scale all in the editor to x100 and apply the transform and export as x1 and import as x1 scale then works.

does that mean in blender you’ve set the units to metric with unit scale set to 1?

Yeah but you don’t need the metric but you can use the metric units as reference, with the normal setup of blender in the default units or metric if you for example got a character of 2m then 2m *100 and apply the scales and then export as scale 1.0

But apply that after end the models and animations, because blender with that huge scales sometimes give problems of bake in the models etc.

2.000 is the same of 2m in blender
2.000 * 100 or 2m * 100 and then export

and yeah the scale in blender its 1.0.

I was curious because I’ve seen a few people having issues because they are scaling during export, there is 2 ways I know of that don’t require scaling during export:

1: set blender units to metric and unit scale to 0.01

2: leave blender units at their default and just use 1 blender unit as 1CM

both ways allow you to export with scale of 1 so using one of those ways might help you avoid the issue entirely.

As i said, with that you going to have problems in the future with blender and that scales for example with the bakes for highpoly to lowpoly models or at least i’ve got problems with that in old projects.

At the end your solutions are the same of i said, before export you change the scale of the models and then export, but only before export creating a copy of the original.

Hi Hevedy,

I think there is a miscommunication of workflow between blender and UE4. Currently, the solution that smokey13 provides is the correct workflow that we typically use when exporting from Blender. When you do this, are you experiencing the rotation error or is it when you do something else. Can you walk me through your exact workflow so I can understand what you are doing and where it might be causing the error? Thank you.

I tested this in Blender & Maya 2016 (i’m noob in maya and is the trial version and i no idea about nothing only export and move the camera) in the Blender using a model rigged by me (the model is not mine) and in maya using a model+project original from COD after export from Maya 2016 with the default settings the model its rotated to a side, and at rotate with the axis rotation in the unreal editor i see the problem.
Then i tested this with Blender and i got the problems when i import or export changing the scale of the model. (But the model and bones are correctly)

How view the problem ?
The fast way: Create a skeletalmesh model in Maya or Blender then export to Unreal Engine 4 and in the import settings change the “uniform scale” to 100 or something different to 1 (if you use 100 with a model from Maya i think you need make the model 100 times smaller before export).
Other way: Make a skeletalmesh in Blender then export with x100 scale and import as 1.0 of “uniform scale” or export as 1 and import as 100.

Then try in the skeletalmesh editor to rotate with the axis tools one bone from the mesh (root bone for example), and check if the mesh move the true º units.

When this will be fixed…

I just came across another issue with blender to UE4. I used rigify to rig the character and when I import it into UE4, it changes the bone names. UE4 replaces DEF-palm.02.L to DEF-palm_02_L. This is an issue when you try to import an APX file from the Nvidia ClothingTOOL. Any ideas on how to prevent UE4 from changing the namespace while importing?

Im having a scaling issue of importing and the sockets being huge i think its the same scaling problem ur referencing

As already said you need to change the Blender scene units to 0.01 scale metric. Then apply scale for the rig first and then the mesh.

There is a known bug in Blender that infects Armatures. The bug is triggered when you
move any of the armature bones around when you’re in the Object Mode. it messes up
all the bones in the armature and rescales and twists them out of position, then once
the bug is triggered when you import the infected rig into Unreal Engine it will begin to
show up as a warped or twisted mangled mess in the animations.

Blender sooooo Seriously needs to fix this bug.

I’m pretty sure i’ve done this before, but I did it again just now, and it still did not work.
well **** it worked after i did your scale metric thing then did a manual scale x10 and then applied scale.
Thanks this is weird and needs to be fixed / semi ridiculous.

That is not a known bug at all. It doesn’t happen for me. You should share a .blend file.

I agree 100%.