Download

Blender to UE4 FBX import error: "Warning: The following bones are missing from the bind pose."

So, I’ve imported a lot of animations from Blender to UE4 before, including Animations I’ve created myself. However, now I’m getting an error and a strange import issue

I get multiple copies of my animation. As if it was cut up into 60+ Pieces. Then, I see this error in my Log.

This is the very first time I’ve seen this happen, and I haven’t found a solution to this yet. Please, any help would be appreciated.

I’ve set my model as Use T0 as Ref Pose, but that didn’t do anything. And I have no idea how to “add them to bind pose” as it suggests.

Depending on the program in use it might not be strange.

You could have all of those animations listed in the NILA list if you are utilising blender for instance.

The best way would be to remove all animation data and start from scratch.

You can copy and paste poses to a new file for instance.

Ok, so I actually have no idea what the NILA list is, but I will assume it is something important related to animation in blender. I pasted the animation into a new file, and on import my animation got cut up less. I was actually able to find a working animation in it, so for right now my project is saved!

Thanks a lot for your help. I was really bothered by this.

When you export FBX from Blender in the export options “Armature” section disable “Add Leaf Bones” to get rid of the missing bones error. This is a compatibility thing with maya and you don’t need it for UE4.

You also want to disable “NLA Strips” and “All Actions” in the “Bake Animations” section of the export panel . That should remove the multiple imported animations problem (probably). However if you do this be sure to select the animation you want to export in Dope Sheet -> Action Editor or blender will not export any animation at all.

With the above and default UE4 import animation settings everything should work out.

I’ll keep this in mind, thank you.

You know, someone on reddit told me that this is an issue within Unreal Engine 4 right now. Caused by the update, or something.

It makes sense to me though. I’m no good with animating in blender, but even I was able to create video game animations previously without changing any settings in Blender. I was even ignorant to the whole NILA thing before I made this post XD

If this is a bug or something I hope they can fix it soon. If not, I’ll try to disable some settings and see where that gets me.

As Waves pointed out, this is caused by the “Add Leaf Bones” option. I would just like to add that to get rid of the “Smoothing Groups” warning you can set the Geometry >> Smoothing to “Face”.

you know, my plugin in has 2 buttons that export with the correct presets for either faces or seams… since right before the last jam.

Nearly all characters will utilize a normal map in their materials. Which makes smoothing groups irrelevant at least for most skeletal mesh exports. Creating smoothing groups is simple but I usually just ignore them since I know that data is useless for most character exports anyway.

Normal maps don’t really override the character smoothing in my exports at all.
if I export with flat shading I mostly get flat shaded stuff where the normal map value is 0808ff…