Download

Blender to UE4 exporting weirdness

While it seems to work, I don’t like getting weird and unexpected results.

Here is what I have in Blender:

blender2ue4_fbx_animated.png
Full: http://s23.postimg.org/7hi5lnv7t/blender2ue4_fbx_animated.png

(red box - export settings)

And here is what I get in UE4’s Editor:

blender2ue4_fbx_animated2.png
Full: https://s28.postimg.org/bhrs8lrq3/blender2ue4_fbx_animated2.png

And this is how it looks on the device (ES2 renderer, Gear VR):

com_Supranormal_GVR_Hellwalker_Z_01_20161222_1853.jpg
Full: https://s30.postimg.org/3osjjiqip/com_Supranormal_GVR_Hellwalker_Z_01_20161222_1853.jpg

How can I get a rid of Armature turning into a root bone in FBX ? (“origin” bone should be the root bone)

What’s going on with shading? I set sharp edges in Blender and smooth shading (if I do flat shading then every single edge will show up on the model and that’s not what I need), and theoretically that’s how it should show up in UE4, but it gives me those artifacts as if it’s expecting to have normal map (from older engine I recall seeing same issue when I was missing normal map). How can I fix that?

Thanks beforehand

Follow the ticked answer here: http://blender.stackexchange.com/questions/49837/from-blender-to-ue4-armature-bone?rq=1

Thanks! I guess it’s time to jump into my Blender add-ons hacking chair :stuck_out_tongue:

Any idea about shading ?

There is some info here:

But that’s what I do anyway (mark sharp edges, smooth whole object, set autosmooth, export). Maybe I need some special cel-shader-like material ? :confused:

Are you importing normals or are you computing them? Sometimes when I import Fox and have Unreal compute the normals (or recompute, rather) it gives me incorrect shading.

Also, I’ve found that leaving flat surfaces shaded as flat instead of smooth helps. Be sure you’re exporting your smoothing group/modifier as Edge instead of face.

Added a screenshot in the OP from the device.
@mws87: I import normals. Also, I can’t have flat shading because I don’t need to see edges around every triangle. Only edges marked as “sharp” should look hard in UE4. I’ll try Edge in the exporter settings next time, thanks.

Ah, gotcha. The Edge Smoothing on export in blender should do the trick, I hope. Also, not sure how you create your meshes, but are you making sure doubles are removed in Blender? I’ve had some really funky results in UE4 that made me want to tear my hair out, only to realize I had extra, overlapping verts & edges, lol. Keep us updated!