Blender to UE4 errors

Hello! I use blender to create 3d models, and have recently tried importing them into ue4. I have found that ue4 has very bad support for blender, it gives errors such as: no smoothing groups, degenerate bases etc. and those don’t go away, which means all my 3d models have the * error symbol. Anyway to prevent this? Will there be better support in future updates?

which version of blender, which version of UE4, and can you post your export/import settings?

degenerate bases usually means your UV map is incorrect. try UV mapping the object, and make sure you are using FBX 7.4 exporter in blender.

When exporting in the fbx options change smoothing from normals to faces and for the degenerate bases your uv seams need to be clean. Blender to ue4 works very well you just need to know how to export properly. The same with any 3rd party software.

I am currently using blender 7.6, UE4 4.8-4.10. And I am also using the 7.4 exporter (It is the default exporter option).

I am using Blender 7.6, so I do not have these options.

The smooth options that is.

look at this picture i have blender 2.75 and I cant believe this option would disappear in 2.76. but i am downloading it now to be sure. until then look here and see the smoothing option just below the check box for “apply modifiers” if you have that change it to faces and that will take care of that problem


wow ok so its a little different but the smoothing option is found under geometrie tab next to main. see picture


now as for the degenerate tangets… are you sure you uvunwrapped the object correctly?

Been struggling with the same issues at first, the answer below are correct and solved my issues as well. I also recommend to always create a second uv layer for lightmapping and optionally create a collision mesh in Blender right away. This video concludes the later:

There is no Blender 7.6… Maybe you mean 2.7.6
Also, Blender and UE4 works just amazing together.
Also the degenerate bases are your fault, because of bad unwrapping.

Ok, thanks. And it gives me the degenerate error every time I try and import something from blender (to ue4), its not something that is project specific.

Could you post a picture of a uv unwrapped object. Usually this happens when veticies overlap or the uv shell is extended beyond the texture space

Of course he means 2.76. Blender has been in version 2 for about 8 years. Since 2.45 it has radically upgraded its ui to the current layout though they have in recent years been heavily developing their node based cycles Render engine its about time they started integrating a more organized menu/submenus system as they have added a ton of features and controls. The down side is when someone grabs the latest version and something is moved like the smoothing group export it can be tough to know what to do to fix errors when you are used to a certain flow.