Download

blender to ue4 cloth apex problem

Hello all,

I’m experimenting with apex clothing but it’s a no go and show for me at the moment.

I’ve tried a very basic set up, with one single bone “Bone”, and a plane with a material “Space”. The vertices of the plane has been mapped to both the bone with vertex group of same name and the material.

I then export the mesh and skeleton as fbx 7.4 and import it to UE4. I open the same fbx file in apex sdk, and apply some max distance painting to vertices. I then save the asset as .apx.

Now this simple procedure don’t work at all:
http://s23.postimg.org/4zl3dij0n/before_Apex.jpghttp://s23.postimg.org/kmccqvwsn/after_Apex.jpg

I’ve tried changing Forward:-Y, Up:Z to Forward:-Z, Up:Y etc. I’ve tried picking a rootbone in apex and generating collision. I’ve basically done exacly as some youtube tutorials.

Why wont cloth work for me?

Thanks for any suggestions or help

Hi, did you solve this problem?
I have the same problem so maybe you can help me :slight_smile:

have you tried this
https://youtu.be/R_W1ymWtOIU?list=PLXWXR2pLy_hV6UwhLjirhNnelWpOzGWRI

btw i would advise a minimum of 3 bones, old rules i know but can save issues later

I also have this problem , adding extra bones doesn’t solve it.

If someone has a solution to this problem, I would really like to hear it. Ive been banging my head on this for a couple of days now.

when export fbx from blender set primary Bone Axis to “X Axis” and Secondary Bone Axis to “-Y Axis”
then will corrent half problem, but some collision object still have local rotation x-axis 90 degree

https://answers.unrealengine.com/questions/437987/blender-auto-bone-orientation-problem.html