Download

Blender to UE4 Armature Name

I am trying to follow a youtube tutorial on how to import skeletal meshes from blender to UE4. The tutorial is this one: ANTWON - JACUZZI (feat. Lushlife) - YouTube

Everything works fine. However, when i’m in the skeleton uasset. it shows me the name of the armature bone along with the root bone. like this:

Does anyone know why this is happening or if it can cause any issues with physics or animation? I’ve been trying to make a vehicle model with skeletal wheels and I’m running in to physics issues with the wheels. could this be why?
Thanks. I’m using blender 2.75a and UE4 4.8.3.

Take a look at https://krisredbeard.wordpress.com/tutorials/tutorial-blender-to-udk-player-model/
and look out for “Stop the armature being added as root bone after FBX export”
And test it.

yes this problem has appeared again :frowning: might be an parenting issue but i’d have to double check that, other wise make sure that the armature/root is set to 0,0,0 and that x-axis is forward and z-axis is up

btw all covered in my blender ue4 tutorials :wink:

lol I think your link is… incorrect.

Also, I would try using a blender plugin called ue4 tools: https://forums.unrealengine.com/showthread.php?34619-ADDON-BLENDER-UE-Tools

It REALLY helps with the process :3

Good luck!

I’m having the same problem. Whenever I import a model into UE4 the engine adds a new root.

@Luftbauch, I went to try the method you linked in your post, but I’m stumped at the point you recommend. I’m not sure how to edit the file? In fact, I can’t seem to open it at all.

ok the easiest solution is to re-name the armature in the data section and auctually use that as your root bone, other wise you’ll have to edit the fbx

looks like there was quite i change in the code to add “leaf bones” so atm i’ve no idea how to edit it to stop it exporting the armature as an extra bone

if you need to add anims to an existing rig that you have in UE4 then export it from ue4 as fbx and import it to blender, that way it works once you delete the extra helper/object on the root

Actually the problem is in the Blender code. I always use the UETools plugin but I also use the above mentioned Kris Redbeard fix. Together they both work like a charm. I just checked the link and it works fine. Though I suggest using a Blender install just for UE4 as opposed to doing this to your main Blender install. This solution has (so far) been absolutely fool proof in every version of Blender and UE4 I’ve used.

I tried this, but it didn’t seem to fix anything.

I went and got UE4Tools for Blender and I’m interested in the Redbeard Solution, but I don’t know how to open .PLY files.

you can open/edit the .PY files with notepad, that’s what I use:).

example path D:\Blender\blender-2.75a-windows64\2.75\scripts\addons\io_scene_fbx in there you’ll find 2 fbx export files , you can open/edit them with any text editor , personally i use a program called Context but windows notepad/editor should open them as well

Ah, thank you. The link asks that I comment out a specific line and save the file. If I open the file in Notepad and edit it, can I safely save it? And will Blender still recognize it as a .PLY?

yes you can safely edit then save using notepad and blender will still recognize it.

Excellent! I’ll be looking into this soon, then. Sorry for hijacking the thread.

Okay, I gave it a shot, but something won’t let me save the edited file. I get a bare “Access is denied” popup. Any suggestions?

Sry, seen to late.
Do you fixed it?
About acess denied.
Close Blender first, then start editor(notepad as admin), try to safe then.
Make a rightclick onto file and look if it is safeprotected.

Thank you, that worked. I successfully edited the file.

Unfortunately, this doesn’t appear to have solved the issue – I tried exporting my skeletal mesh again, but the base armature is still carried over.

thats because 2.75 uses the export_fbx_bin.py file , unless someone knows what to edit on that

Hmm. I went in and searched for line from the older file, thinking they might share it, but they don’t. So, I guess I’m stuck again.

Can you make a wireframe picture of your model, or upload the blendfile?
Then i can look into/replicate, when coming from work, in some hours.

Good idea. Dropbox okay?

And here’s how the bone hierarchy looks at the other end in UE4:

As you’ll see in the blend file, I renamed the skeleton itself to Root in the hopes of smoothing things over, but no dice.

Thanks for your time and effort.