Blender Socket Help

I am importing a character animation from blender everything seems to work fine until i add sockets to bones. The sockets are large and cant be scaled in engine, the scaling of the model and skeleton are fine it is just the socket is to large. I can’t seem to find a solution for my problems does anyone know why this might be happening and what I can do to fix the socket size. Any help is appreciated.

Make sure to take a look at this thread: https://forums.unrealengine/showthread.php?86216-Skeletal-Mesh-Small-in-Mesh-Editor There we are already discussing what could cause this :slight_smile:

I found a fix for the large socket, I renamed all the bones to the same name as the rig that ue4 provides. that seems to have fixed the issue with the socket.

hey PubMonkey, that really doesn’t make sense actually because adding a socket should work on any skeleton, regardless of naming conventions.

unless you got rid of the armature showing up as a bone by renaming the skeletal hierarchy, can you go thru how or what you used to rename your rig?

so far, from what I can tell the armature still gets used as a bone etc. when getting a skeletal mesh into UE4. the armature doesn’t keep any true scale information that I can tell & shrinks the skeleton down by 100 - .01 (or centimeters) so either you have removed it from being used by UE4 or have exported it where the scale is correct, which usually messes up any mesh scaling information that is with it, which causes weird results in UE4 especially when retargeting and obviously when adding a socket as well.

did you use some method or script for renaming the bones in your rig? or how did you deal with the armature when exporting/importing?

I agree but i am using the same blender file and that was the only thing i had changed and than it worked I agree that it shouldn’t but that was the only thing that was different. in honestly I am not a animator so working with skeleton are new to me like i said that was the only change i made I also changed the axis for the export before the one that worked(blender axis are reversed on the z axis) I renamed by hand looking at the rig that the twitch video gave out. Exporting has been the same settings i used since watching the first twitch stream for blender to ue4

well still glad it’s working for you, have you tried retargeting to the UE4 skeleton yet? and then retarget the animations to your rig / skeletal mesh?

luv those stream videos btw, which version of blender are you using and are you using the export settings that’s given in the stream video?

just curious about how well this has worked out for you and how well it works

reason for all the questions basically is Blender 2.75 basically works now, even for animations
but issues arise from the silly armature problem that seems to still scale down the skeleton and is shown in the hierarchy when imported into UE4

most of Blender’s export problems were fixed in 2.75 except the silly armature thing, wish Unreal would make Persona where it could ignore or remove bones from the hierarchy in Persona, I think retargeting & sockets would probably work right then. but I’m no expert.

Nsomnia (UnrealTek / BlenderTek) put up a video that describes how to get the skeletal mesh then the animations in UE4 from Blender 2.75 - just ignore the problem he had in the end, I think he renamed a bone which caused some errors - but it works, just don’t rename things, lol. great work btw, Nsomnia :wink:

I am using blender 2.75 and UE4 4.8 and the settings are the same as they use in the twitch stream. no haven’t re targeted nut ya maybe i did something without realizing it but it seems to be working for now.