Download

Blender Skeletal Mesh: Component Position Scaled From Local

I’m trying to make a vehicle skeletal mesh using the UE4 vehicle system. However, my physics are acting up and the wheels are not working and it’s due to this issue of the skeletons component scale not being in line with the local scale.

Here’s what it looks like:
Capture.PNG

Does anyone know why I’m getting this issue? I’m using Blender 2.75. Are there any settings I need to change about my blender scaling/scene setup/exporting to make the workflow of this smooth? Thanks.

yep might be an idea to use 2.74 as 2.75 adds the armature to the rig as the root, apart from that try following my blender ->ue4 tutorials

basically root must be 0,0,0 aligned x=forward z=up , wheels must be x=forward z=up

mesh created so that the wheels are touching the ground

I’ve tried using 2.74 but now I’m having more problems than I did with 2.75. The component and local numbers are still different, and when I try to add an animation to my skeletal, the scale becomes tiny.

ok which ever way you do it , do not use any form of scaling on export or import as this will likely mess up your work

  1. sort out the size of your skel mesh in blender , reset all scale/rotation (ctrl+a) then export and check in ue4, if ness modify in blender - reset scale/rotation and export again
  2. once your happy do your anims in blender and export then one at a time, this helps till you have the workflow sorted
  3. i realise that there are options to sclae on export and import but afaik most people have to many problems with it