Download

Blender 'Send to Unreal' Plugin Character Scale Problems

Hello,
I’ve been working on my game to close to a year now and I’ve hit a snag with importing models for characters. I made an edit of the default Mannequin and used the official ‘Send to Unreal’ plugin with the settings set to use the existing skeleton at
“/Game/Mannequin/Character/Mesh/UE4_Mannequin_Skeleton”

image

The result in UE4 is exactly what I expected- a skeletal mesh with all the bones in the right places. Everything works fine including the model’s scale- until I set it as the skeletal mesh for an actor and the animations are active. When I do this the model is 100x bigger than it’s supposed to be, but if I clear out the “Anim Class” so the animations don’t play, then the scale is normal. I’m still using the default third person character animations currently.

I also tried this without editing the mesh to make sure it wasn’t something I did:

  • Export the Mannequin mesh from UE4
  • Import the Mannequin FBX to Blender
  • Put the armature and mesh in the correct collections
  • Use ‘Send to Unreal’ with the same settings as the above picture.
  • Set any Skeletal Mesh Component’s Skeletal Mesh to the new mesh and enable the animation blueprint.

Same result.

Worth noting is that the imported model in Blender is parented to an empty at 1/100 scale. If I apply ‘All transforms’ then this all works with no problems… except the thumbnail generated in the asset browser is 100 times smaller than it should be and effectively invisible. Not the worst outcome but it’s not ideal.

There must be some settings I’m missing to get this to working but I can’t find anything that looks like it would be the solution.

Blender version is 2.83
Send2UE version is 1.8.4

Thanks

I don’t use that plugin, I use the FBX exporter and the same issue arises. Animations show up 100 times smaller then the skeletal or the mesh. I tried a lot of settings combinations and I think there’s a bug somewhere in blender.
There are a few workarounds for this, but I can’t find one that’s ideal.

Oh that sucks

Should I post an issue on the Github page? Are there any other exporter plugins I can use instead that actually work?

I found an addon called Mr. Mannequin’s Tools. It works perfectly

You don’t need plugins. Exporting using the blender exporter is simple.
The simplest workaround is just to rename the armature to something else then “armature”, that will solve the scaling issue.
Use the following export settings:
-Object types->armature, mesh
-Geometry->Smoothing->Face
-Armature->Check “Only deform bones”, uncheck “Add leaf bones”

You can save this settings using “Operator presets”

1 Like

Hey it worked! Is there a way to have this export each mesh in the scene as a separate fbx though? I’m going to be using modular characters and this would be really helpful to not have to export each part one-by-one.

I don’t think so. If there are many parts, that will be a pain…
Have you tried the plugin with the armature renamed? Maybe that will solve the problem with the plugin too.

1 Like

I looked through the settings of the Send to Unreal plugin again and I may have found the culprit.

image

I unchecked this option and now everything works perfectly.

Thanks for your help

I’m going to check that plugin and maybe I’ll used it too.