Download

[Blender] Same model but different shading quality?

I exported the trashcan model from the reflections subway demo then re imported it into a blank project.
I then imported it into blender, changed nothing, and exported it again.

When the blender exported model is imported into ue4 and the original file is imported there is a very obvious difference in shading quality under the same import settings.
I’m not sure how to get around this, I have thought for the longest time that my lightmaps have been the issue but it seems like blenders fbx export is a bigger issue.

I am currently using the preview build of blender 2.73, but the issue has been around since I began using blender and UE4 together.

I suppose I would like to ask if other blender users have better luck importing?
And if so what model preparations or export settings do you use to get around this?

I’m going to try a bunch of things and try to find a work around myself in the mean time. If I find anything I will update the thread.

He is the same trashcan imported twice, the left is from blender, the right is directly from reflections subway.
Screen01.png

It’s a smoothing issue, something done in Blender or when imported back to UE4 changed the smoothing.

Maybe try appling flat shading, and then smooth shading back again in Blender before exporting. The smoothing issue may be connected with the smoothing groups in the model, and reapplying smooth shading may fix that.

Definitely a shading group issue. You can see at the bottom of the can that the black parts are geometry-based where the vertex normals are having a bad day. I only work inside Maya, so I’m going to describe to you how I fix this and you may have to translate it into Blender terminology.

It could just be export settings, so you might take a look at this and see if you can notice something like a missing checkbox called “Smoothing Groups” or something about normals: https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/StaticMeshes/index.html#exportmesh

In Maya, you can either “Soften Normals”, making faces one smoothing group that is shaded like a rounded object. Or “Harden Normals”, which splits the smoothing groups and creates hard lines or faceted faces. For some reason inside Maya, every once in a while the vertex normals get really messed up and neither of those options works at all. In these times, I “Set to Face” the normals, meaning I reset them to their default position, and then they behave normally and I can edit them how i like. I’m setting all this up just to tell you to find some sort of blender option that will set the Smoothing Groups or Vertex Normals back to the default angle, which is usually “hard”, then edit them from there.

blender and smoothing groups oh how blender foundation seems to hate the idea of applying smoothing groups logically, Max has the best smoothing group editor i have seen yet. try smoothing the mesh and going over the sharp edges with a sharp edge modifier, ctrl E i believe its the same one used to mark seams, this should fix the problem however it will break up the model into separate pieces on export, however i think it would normally anyway, as i was reading something about smoothing groups when i was messing with cry engine and using to many smoothing groups hurts performance, not sure how that would work here but i have never had any problems with it.

Unfortunately I think it has to do with the fbx export in blender.

I tried many different combinations of export and found this

HighresScreenshot00000.png
The image on the left is a direct import from the reflections demo, middle is FBX 6.1 ASCII, and right is FBX 7.4 Binary

Without any changes to the model the quality of the shading/smoothing decreases with the newer exporter.
I tried a lot of different things within blender based on all of your suggestions but I had no luck.

I’m afraid it will become more a matter of waiting for blender to catch up.
I will keep trying to look for workarounds I suppose.

when you import to UE4 what setting are you using for the normals?, I have had some similar results when using “calculate normals”, if you haven’t already you could try changing it to “import normals”, might help might not:p.

All the images are with imported normals, calculated looks worse and normals and tangents doesn’t look any different.
I have been toying with blenders auto smooth thing but the results are mixed.

You should do one more thing to test the Blender exporter properly. Simply create a model like this in Blender and then export it. The whole problem may be generated when you import the model from UE4 exported mesh into Blender. I’m using Blender myself and I haven’t noticed this kind of shading issues, but I will yet need to do some testing. I have been toying around with a lot of low-poly meshes and some really big environment pieces in UE4 so far, and I did not test any smaller, rounded objects. And I have never tried to export a mesh from UE4 into Blender just to import it back to UE4. This kind of workflow makes no sense in real life scenario, so it may be be that the whole problem is not worth your time.

One more thing is that since 4.6, I think that UE4 started displaying a warning about missing smoothing groups for Blender exported .fbx meshes. It didn’t do it before. Also try posting that last screen on Answerhub, so maybe someone from Epic will take a look at it. Just wait until 6th of January, when they are back from vacation :slight_smile:

Hi, MrDoxies. I’ve been using blender as my modeling workflow for UE4 for months. I found a decent way to export FBX from blender to UE4. When working with smoothing group in blender(Only for UE4 workflow), first, you must mark all sharp edges which are supposed to be sharp by selecting those edges and Ctrl+E to open the Edges menu then click Mark Sharp command in the menu. Next step, you can just export FBX with setting smoothing mode to “Edge” in exporting settings, don’t apply any Edge Split modifier when exporting, you can preview the smoothing group effect by adding a Edge Split but never actually apply it (Important for UE4 FBX workflow with Blender currenly!). By the way, make sure the entire geometry is smooth shaded, if not, you should select all edges and execute “Shade Smooth” command. That’s all. Good luck.:slight_smile:

Awesome_Junior_Miss’s solution worked really well, it added 189 vertices to the model but the result is perfect so it’s fine.

The following models I took rimau’s advice and created a similar model myself instead of importing it from the reflections scene, however The results were the same as the re imported models.

I then took Awesome’s advice and used the mark edges sharp and export with smoothing set to edge and the results were perfect. I did have to make sure auto-smoothing was off and there were no modifiers on the mesh to get it to work properly.

Each of these models is the one I had made similar to the reflections scene trashcan
HighresScreenshot00001.png
Left is ASCII smoothing set to face, middle is Binary with smoothing set to face, Right is Binary with smoothing set to edge and edges marked as sharp.

Thank you to everyone who helped solve this, I had thought for the longest time that the issue was in my lightmaps.
Hopefully blender adopts a better solution to smoothing groups that doesn’t force us to add more vertices.

blender does have a proper smoothing groups solution. UE4 adds more verts to hard edges between smoothing groups anyway so its unavoidable, using baked normal maps can help with that.

Thank you for this! I was using the face method when exporting the FBX and was trying to figure out the correct setup.

So basically what I gather is that UE4 is splitting the edges that we mark sharp correct and adding vertices?

Thanks for the tips and testing all this out guys. This kind of issues can be a real pain sometimes :slight_smile: