Blender models into ue4

Hello, i am trying to take a blender model and stick it into ue4. I cannot get the model to show in ue4 when i play. It becomes invisible? Also i cannot get the textures/materials to load into ue4 all become white when imported? - Thanks


-have you already built your light?
-add a skylight to your scene
-what happens when you drag and drop your meshes into a template scene?

The thing with the textures ->
-make sure that you mesh is uv mapped
-use png or jpg images
-make sure that those textures are still at the same place
-or just manually import the textures :slight_smile:

Hey Drunken Master, in my experience, the DevKit works best with .tga files. You should easily be able to “export as” .tga in most image editors. Once you get the textures imported, you will have to build a “material” that you can then put on your static mesh. Building the material is actually really easy though!!

Just right click in the DevKit and select “new material”, once that is open you can highlight your texture, then in the material window, hold “T” and left click. That will auto drop your texture into the blackboard, and from there you just have to connect it to the appropriate node. If you come across any problems, please let us know!

I got it all worked out from above but now im noticing when i play it in ue4 it pretends like my blender model is a huge block? i cannot walk on the flat seams?Have them set to blockall also tryed ground for collisions in ue4. I walk up to it and try to walk over road and it just acts like one solid block? Also building acts like a huge solid block? im not sure if this is blender or ue4 issue a bit new too both.
Blender photo example:


It sounds like when you are importing, you are having UE4 create the collision. You will have to go into your structures settings and custom build the correct collision parameters for your structures/objects if you are experiencing this problem.