Download

Blender is making me cry

And I don’t like crying because it ruins my image.

Does anyone have a rock solid workflow for getting animations from blender to UE4? I’ve been using Blender 2.71 and UE4.2.1. I just get problem after problem and when I solve one, another appears. I’ve followed so many tutorials now I’m starting to lose track. It has become by far the biggest bottleneck for my game.

Does anyone have any advice on how I should proceed? Do you Max/Maya using folks experience similar troubles? If not then I may have to consider switching :frowning:

Which kind of problems do you get, because my team and I are exporting skeletal meshes since february without having any problems? :slight_smile:

We use a very simple workflow:

  1. Creating the rigg (just a ordinary one which is shown in every rigging tutorial)
  2. creating animations (we also create them like in the youtube tutorials)
  3. scale everything up or down → Object - Apply - Scale/Rotation/…
  4. export it -> Mesh + Armature
  5. Import it with the base settings (enable import animation)

Ok well I’m glad to know that it is possible so I’ll continue to work on it.

It is difficult to even begin describing my problems they have been so varied. They have included the following:
Crushed meshes
Completely destroyed meshes with missing sections
Missing bones
Armature not aligned with the mesh
UE4 just crashing when attempting to import

I’ve decided to take a step back and simplify what I’m doing so I can get the workflow correct on a very simple model first. Hopefully I’ll be able to ask a more specific question shortly.

Ok, so quick update:

I stripped everything back and just animated a leg with no IK bones, or targets or anything. I’ve now got it correctly importing into UE4. Key to getting it to work was not touching the weight painting. Everything seemed to go hell in a hand basket if I touched the weighting (UE4 crashed when I tried to import it).

I’ll now try and extend my armature to a more sophisticated model while being careful to maintain the same settings.

nice to see your getting there, lots of people here use blender so if you do have workflow issues just ask

I finally successfully export animation from BLender 271 to UE4 after many trials and errors. I’ll make some screenshots tutorials on some new thread.

Nice! Make sure to post the link to the thread in here :slight_smile:

Please post the file that crashes UE4 over at https://answers.unrealengine.com/ so the engineers can have a look.

I’ve been getting the same thing. I’ve tried everything. The one pattern I notice is the PSA totally destroying my model.

In Blender, I’ve rigged my model…somewhat decently. I like to think I did, at least.
I made a quick little test pose to, well, test it.

(Yes, I am aware the right arm looks a little odd)

This is the my model in Blender:

Now when I import the .psa file, things go totally wack:

Note the obliteration.

If I export as psk. and import, the animations don’t load:

(program closes immediately after)

If I import the model into the already existing player package, it animates but is HEAVILY distorted.

Why dont you just export it as an fbx file? :slight_smile:

“I tried everything” does include FBX. There’s a reason I said “everything.” :frowning:

0h, and this is for Killing Floor, so I can’t import FBX. I tested the FBX in the new Unreal but I got the same problems. I even tried exporting FBX, opening it in 3DS, and testing it there. Importing the .psa’s does the same thing.

Probably this thread helps you: https://forums.epicgames.com/threads/982833-Blender-Psk-Export-Shenanigans-(Incorrect-Deformation)

When you upload the model we could take a look at it :wink:

I read through this, and am attempting to use MilkShape, but I can’t seem to get my model from Blender to Milkshape. :frowning: I’ve literally had nothing but my own work go right on this.

When I export from Blender to Milkshape, Milkshape gets something like this:

Have you probably scaled your mesh before exporting? -> When yes, then go to “object” - apply - scale/rotation/location

Ah, thanks, that fixed the aligning problem, but uh…this still doesn’t look quite right.