[Blender] Impossible to get animated rig "working" inside UE4 [SOLVED]

[SOLVED] Will post a video tut when i have time about how. Main problem was not having ref 0 enabled.

Hi,

This is exporting from blender → fbx → into UE4
I’m having trouble getting any kind of simple rig on a simple model to work proper in UE4.
Ive checked many things, my bone scales are 1,1,1.
I have applied the scales on everything
My animation is simple and starting from 0 to 30 frames.
But once i try to import it i get the following bugs.

(Btw i do not get any errors from UE4. The import just goes wrong as follows:)

It looks as if my UE4 is thinking that my model is bigger then it really is.
Its hard to find it in the 3d model viewer inside UE4 because i need to zoom in all the way because again.
Its counting allot of empty space as my model. Which its not.

Then when i put the model inside my game. It lays on its back and is tiny.
But when i have it play an animation. It suddenly grows into a huge model. that “does” play the animation…
Ive been messing with this for… like from 9 till 8… and i’m getting a bit fed up now to be honest :stuck_out_tongue:

I really don’t wanna go back to Unity just because i cant import any models.

Hi VRF,

Have you made sure to set the blender scale to uu instead of the standard blender scale? Additionally have you made sure to only have one root bone?

Yes i have even matched the scale with the HeroTTP .fbx file just to make sure orientation and scale were correctly. And yes i have only one root bone.

actually ended up using same model just redoing things.
just seems that it keeps the same bounding box as first scale.
but when animation applied it shrinks it down by perhaps a 100 factor.
it looks as if the animation does not export with its scale.
errors seem to have become less though for some magical reason.

http://i.imgur.com/zNCjKx8.png

http://i.imgur.com/vg1CIkR.png

http://i.imgur.com/YLs70P3.png

http://i.imgur.com/aya1ahp.png

http://i.imgur.com/DooHiOm.png

http://i.imgur.com/R3yeqMg.png

Is there anything in the animation itself that may be affecting the scale? I haven’t been able to repro this on my end, are there any steps you can think of that I can take to see these results?

Hi Adam, thank you so much for your attention and help :slight_smile: I got it fixed ultimately. And am now working on getting animations imported :slight_smile:
Did a few animations already for testing purposes and fun.
As you can see i put [Solved] on my title here :slight_smile:

heres a shot of me celebrating my workign import XD :stuck_out_tongue:
alt text

Hello VRF,

I’m having exactly the same problem. Where is the “ref 0 enabled” setting you are talking about?

Hello VRF

Unfortunatelly I have the same problem aswell. Would pretty much apprechiate info about your solution.
Thanks

Hi ferocildo,

There is a button that says advanced settings when you upload.
It should open more option and then showcase you the ref 0 enabled button.

If you still have trouble finding it i can make a screenshot for you.

Hi VRF,
Is the option I highlighted on the picture the one you had in mind? If not would you please post that screenshot?

Hi would you please submit screenshot of your ref 0 enabled button? Or any other info about how to unSmurfify my character? I really really need to solve this. Thx in advance

This is the process I take to make sure my rigs work correctly:

  1. Set your scenes units to metric with scale of 1
  2. Import your model into blender (unless you already have one made in blender)
  3. Add 1 bone enter edit mode
  4. Scale and rotate bones to the correct size while in edit mode if you have the wrong scale or rotation on your bones in edit mode they will reflect that in ue4 but not blender(this step can make or break a proper bind to your mesh)
  5. Once you have your rig to the correct size and rotation within edit mode, it’s then time to bind your rig to your mesh, next enter object mode, and select your mesh and rig and hit ctrl+p bind with automatic weights
  6. Fine tune with weight painting where necessary
  7. Select your rig go into pose and select each bone, enter object mode and select the rig and mesh
  8. Export fbx with following settings: only settings that need to be changed from the default are Z up and the forward axis should match which direction your rig and mesh are facing, check “selected objects”, highlight mesh and armature set scale to 1
  9. Hit export
  10. Go into your project’s content browser make a new folder that represents your animations
  11. Click import and and select your fbx
  12. I don’t change any of the default settings when importing (I don’t use toa ref pose) hit import all
  13. Cheers you now should have a working skeletal mesh or rig or both

Hope this helps :slight_smile:

Just solved in now. So never mind :slight_smile:

Hello Steve,
I have already solved the problem myself as mentioned before(I use rigify, when i generated the rig scaled it properly and applied scale, it was not respected while importing. I solved it by matching scale to UE4 before generating rig, than exporting at scale 1). But thanks anyway, your summary workflow is helpfull list of things good to keep in mind.
Happy blending :slight_smile:

StevenShortridge, running UE4 4.8.2 and Blender 2.75, your steps worked for me.

Slight thing I changed was Blender’s Scene measurements. I tried setting it to 1, but the mesh was huge. Trying to scale it down wasn’t working as expected using the scale widget, so instead I set Blender Scene measurements to .01 (as this guy recommends Blender to Unreal Engine 4 in a Nutshell - YouTube ). Following all the other steps you indicated, everything turned out perfect.

The rig used was created using the Pitchipoi rigify addon.

Thanks to the OP for starting the thread and clearly stating the problem and the fix. And thank you very much for taking the time to write your fix out, StevenShortridge. Much appreciated…!