Blender imported mesh rough edges

Hi all,
My problem is seemingly widespread but I could not find any question that is exactly the same, and any solution in a similar question did not work for me.
I have a simple mesh I made using Blender, exported to FBX and imported into UE4. After the import process, I get these obvious face coloring due to lights hitting the mesh.
The thing is, that if I use Datasmith to import a similar shape made using CAD software, one can clearly see that although the polygon count is much lower using the tesselation process, the shape appears smooth in UE4.
I need to use the Blender version, importing from CAD will not do the trick. I’m not even sure if the reason for this relies in a UE4 configuration or a Blender one.
I have triangulated the Blender mesh, tried to export from it using all possible smoothing types (normals, edges, faces, with/without tangents) and importing to Unreal using “calculate normals” and “import normals and tangents”, nothing worked.
What am I missing here??

Try adding face smoothing to the faces you want to have smoothed

Red object: Shade as flat
Blue object: Shade smooth


Thank you! That did the trick. In other places where I searched, it was stated that this is only a Blender internal property that is used for rendering and does not affect the mesh. Apparently it does affect the way the mesh appears after the import (exporting with face smoothing option is still a must, though).