Download

Blender Fbx export: Could not find any node.

All I did was make a basic cube in blender and export it with normal options. Then when i try to import into unreal, it says could not find any node. I’ve done this before in the past, but now it won’t import anymore. Is there something special I have to do now to keep from getting this error? I can’t find any information about it other than use ASCII exporter ect, which I’ve tried already.

You should post the .blend.

Ive had the same problem with max, it just happend with one of my meshes, the way i fixed it was to exsport the mesh as an obj then reimport it into max and then exsport as an FBX agein, i know it sounds crazy but it seemed to fix the mesh, so you never know might work

Try putting the import settings to default when you’re importing to unreal engine, maybe you accidentally changed a setting which you never noticed, maybe that’ll help

What fixed it for me was adding a cube in Blender (in the same position as your object’s origin), selecting object and then that cube, ctrl+j to merge them (now the properties of cube override the ones of your object - smoothing angle threshold, transforms…) and in edit mode removing the faces that you don’t need. Now as you export it - it will work.

Why this is the case: I still have no idea.

I had this issue which turned out to be simple, I had a SM_ and UCX_ (collider) in my blend and I was exporting ‘selected objects only’, however - I’m not sure which - something or another was selected. Meaning I didn’t have to both meshes selected. Simple error, point being check exactly what it is you are exporting if you get this error.

TL;DR; Make sure the object names (in Blender) that you export to FBX do not include the substrings: “UCX”, “MCDCX”, “UBX”, USP", or “UCP”.

This one was difficult to track down, but in my case this error was because I had an object in Blender with “UBX” in the name. Why would this cause it to fail? First off, when you export from Blender, all of your objects become “nodes”. I inspected my FBX files with Autodesk’s Python FBX SDK, but there didn’t seem to be anything different about files that worked and those that didn’t.

So I debugged the engine code and it turns out there’s a function called during the Unreal FBX import process, FFbxImporter::FillCollisionModelList(FbxNode* Node), which looks for the following substrings in node names, so that it can process them as collision models: “UCX”, “MCDCX”, “UBX”, USP", or “UCP”

You can reproduce this error by:

  • Creating a new Blender scene
  • Renaming the default cube to something like “asdf83MCDCX”
  • Exporting that single cube to FBX
  • Import to Unreal and get “Could not find any node” error

There’s technically nothing wrong with this FBX, but since it has that special word in it, Unreal thinks you don’t have a real mesh in there.

1 Like