Blender FBX degenerate tangent bases

When I import my model (using the settings found in Blender & UE4 | 01 | Live Training | Unreal Engine - YouTube expect that I only exported mesh and in unreal I didn’t import as skeletal since it is static mesh) it says: “knight_11test has degenerate tangent bases which will result in incorrect shading.”
I tried some experimenting and figured out that it’s caused by mirror modifier. (I didn’t forget to apply it.) same thing happens if I duplicate the mesh in edit mode and scale it by -1 on x axis to mirror it manually. (I recalculated normals after this).
My blender version is 2.73a and UE4 version is 4.7.2
Does anyone know how to solve this or do I need to model both sides?
If needed I can send both the blend and fbx file.

p.s. English isn’t my first language so I’m sorry if there are any errors in my post.

I’m sure someone will get to this before I can get home and experiment with what you’re talking about, but I’ve had some difficulty in this before. There are some things to watch out for. For instance I found that if your object has thickness and you use the mirror modifier without getting rid of your faces on the edge of your model you will wind up with inner faces that can make for some nasty artifacts. Did you check clipping under the options? Something else to try if you haven’t already is the Mesh Lint addon. It’s a great help!

This means that you have to create UV maps inside of Blender.

To create UV map = Select each single object, go into edit mode. Click A to select all -> hover over the object somewhere and press U -> Select Smart UV map. Do this for each object you have, then you can export/import into UE4 without the tangent error. But it could also mean you have artifacts. Not entirely sure.


It works, thanks!