Blender fbx 6.1 ASCII "Armature" bone not removed by Unreal

Hey everyone, I have an issue regarding Blender in which Unreal fails to remove the “armature” bone of fbx exports utilizing fbx 6.1. The “armature” bone for exports utilizing 7.4 binary are removed, however. Is there a solution to this?


The solution is to not use the deprecated 6.1 ASCII exporter. :stuck_out_tongue:

Thanks again :frowning:

Sorry for posting again, but I have a small question in case you can answer it. The reason I want to use the ASCII exporter is because I can’t use unreal-exported fbx files in Blender. I can’t, for example, export a skeletal fbx from within Unreal (made with Blender), open it in Blender, make changes, then re-import it into Unreal. The export file always looks different in Blender and Unreal for some reason, so it fails to merge bones when I try importing back. The only real solutions I have found are:

  • The ASCII exporter which works just fine (except for thread-related)
  • Exporting from Unreal, deleting the original mesh and skeleton IN unreal, making changes in Blender, and re-importing that file. Any further changes re-import just fine.

Do you know of any other options? (lemme guess, not to use the UE4 exporter ;))


Well yeah, why are you exporting from UE4 back to Blender when you originally made it in Blender? Just edit the .blend file instead? :stuck_out_tongue:

It worked for me though, but I had to rename the empty everything is parented to to “armature” so it’s removed instead of creating a new root bone in UE4. There’s no point to this though, just use the original .blend file instead.

It’s because the animations are already made; I’m re-targeting them to the Blender skeleton, so if I want to edit those animations in Blender I have to export them from Unreal, and the Unreal export is incompatible with the Blender mesh. Sorry if this is confusing, I’ll try to reiterate:

  • The original mesh was made in Maya, we moved it to Blender.
  • We import it into Unreal as a new skeleton, and retarget our old animations to the new skeleton. For the most part, they work just fine. That being said, there are some manual touchups we’d like to do in Blender.
  • We export the retargeted animation from Unreal and import it into Blender to modify it.
  • The retargeted export is different from the original import, making it difficult to modify it

Do you understand? Sorry if it’s still cloudy, I’m confused myself to be honest. Thanks again for the help :slight_smile:

Also what do you mean by renaming the “empty everything”?

Well you should have said this from the beginning, this is a very different issue. :stuck_out_tongue:

What you need to do is open the retargeted animation, then export using Preview Mesh, it will export the retargeted result. Open (import) that in Blender, make sure it looks okay with frozen transforms (eg. at 0 it should look like a normal Blender rig, if not rotate it in object mode and apply transforms).

“rename the empty everything is parented to” means just that, rename the Empty everything is parented to. But maybe it’s not necessary if you export using the above method.

This worked! I didn’t see that I could export using preview mesh, thank you! And yeah I was unclear reading over it again, thanks.