blender export vertex issue

I get this issue when exporting the model

all vertices are weight painted to 3 bones, this issue only appears once imported to UE, please help! it’s driving me nuts.

Looks like some weight-paint issue to me. Did you get any error/warning while importing in UE4 (like the weight of some vertices was put to root)? I remember I had a similar issue some time ago and as far I remember I fixed it via normalizing the weights in Blender (there is some button in Blender to do that). I think some got too less weight - even if you weighted it already to bones. Is the sum of weigtht of that vertices 1? If yes then I would double-check all vertex groups in weight-paint mode and verify if there is no weight-paint-smudge somewhere (like it could happen by mistake if you paint on top the head and get a little bit of paint to the feet for example).

Brilliant, thank you!

Oops, I was so excited I forgot to mention it was normalizing the vertices that fixed it :slight_smile:

thank you, it’s fixed, how do I close the thread?

Just leave it here. :slight_smile: This will help other people with a similar problem, later.