Download

blender digital fbx not include all animations

I am trying to export a skeletal mesh from Boehner to unreal 4 using the digital fbx in 2.74 blender. Everything looks cool in unreal except I have some 20 animations but I only get 5 of them in unreal import. I have tried many things but would appreciate and guidance on why this would happen… when I use the analog fbx I get all animations but my scale for the mesh and animations are really messed up. Thanks in advance.

I don’t know what’s “proper”, but I do all my animations on one timeline and split them up in UE4.

Blender has the ability to make several actions and the NLA stuff…which is beyond my current understanding. I just put it all on the same timeline and mark the frames I’ve set everything on, then import with Animation checked but NLA and All Actions unchecked.

I do have a weird issue still where the frame the keyframe is on in Blender doesn’t match in UE4. Haven’t quite figured that out yet but I’ve worked around it in UE4 so far. For instance, something that is on frame 30 in Blender might be at 30.45 or something in UE4. I thought it was an issue with the frames per second setting in Blender but that didn’t seem to change anything.

I finally got it working… basically I had to push all animations actions to NLA strips. Then in the export I selected NLA strip and deselected “all actions” this created desperate animations in unreal, all I had to do then was change each animation to use the “by ref” and the animations are looking perfect…

Yeah I had toyed around with NLA before, but I got so confused at one point I said forget it and did them all on the primary track.

It seemed like it would have been nice to have all my actions in separate strips…maybe I’ll have to revisit it. Blender’s animation interface kinda ticks me off for some reason lol.

Is there a simple way to select a range of frames and move them to a strip?

I’m glad you got this solved, but here’s another thing you might want to look at that’s caused me problems before. I’ve never had to push to NLA to get the actions to export, but I have had problems with animations not exporting. The root cause is usually a name mismatch on the armature object. So, if you have a character you’re exporting, and the armature is called “Root”, but some of your actions have a root animation node called “Root.001”, they won’t export along with the model even if they work perfectly fine in Blender.

I actually have a Python script I use to clean up Blender animations, and one of the things it does is to make sure the action root object name matches the actual armature’s.

May not be your problem, but thought it was worth mentioning.