Download

Blender building uv unwrap

Hi epic,

I made a rock in blender and baked the normal map from the high poly to the low poly mesh, when I put the material onto the mesh in unreal i see the uv unwrap seam only when the normal map is activated.

http://s27.postimg.org/8qr7fysrj/Capture.jpg

Is this a common error or have I done something wrong?

Check your normal map asset and make sure flip green channel is checked, this is because blender and UE4 use different conventions for normal map green channel. Second, make sure you checked export tangents in blender, and checked import normals and tangents in UE4. This is because blender has to bake the normal map with specific tangent spaces and if you tell UE4 to recalculate its own tangent spaces they might be different and you’ll end up with errors.

  • check if you have set the mode of your texture to “normal map” -> in the texture settings and in the material :slight_smile:

Hi guy’s,

Thanks a lot flipping the green channel did the trick really getting seamless uv is hard in blender but after using some texture paint it is hardly visible.

My result:

http://s16.postimg.org/mpqkjm7z5/Capture.jpg

If there is any trick to get better seamless results pls share!

Greetings,