Download

Blender Armature to UE4

Hi,

I’m trying to import a simple mesh rigged with Blender in UE4. When I drag and drop the skeletal mesh in the UE4 viewport, it looks right, but as soon as I add the animation,
(Details ->Animation->UseAnimationAsset), the mesh is getting way smaller :frowning:

In Blender, I’ve set the units in Metrics (scale 1.0). My rig and my mesh have a scale of x:1, y:1, z:1. (I applied the scale with Ctrl+A, as always).
My export settings for the FBX: scale: 100, Armature+Mesh.

Dose anybody have the same problem ?

Kind regards.

Hi,

Yes, I have the same problem.

Besides having the scale problem, I also have a problem with some twisted bones. The animation plays ok, but one bone is reversed or badly twisted.

If I try my exported .fbx with Autodesk FBX Viewer, the same problem with the twisted bone happens. On the other side, the same fbx is imported correctly in Unity3D.

This is my only problem with Unreal Engine 4 now, If this is solved… I would definitely quit from Unity3D. But my animation pipeline is not working because of these two cases.

I hope this gets fixed in the future. There are two ways of solving this, either Unreal supports these special cases… or someone in Epic gives more information to the guy creating the blender .fbx exporter on how internal things are handled. I already spoke with him and he says that he is aware of the problems, but still haven’t figured out how to solve this on the export side. The .fbx is theorically correct. Maybe the scale in the skeleton is not handled correctly in UE4? Unreal expects a scaled mesh (scaled vertex coordinates) instead of exporting with scale 100 in the fbx?

If I have time in the near future… I will try to fight this problem.

By the way… I will upload a small lowpoly animated mesh that suffers from this in order to help someone look for the problem. It’s small also in size, so you can not se it once the animation starts playing inside UE4 because of the scale problem:
https://dl.dropboxusercontent.com/u/7549551/Octopus.zip

Hope we can help to solve this…

Cheers!

I honestly think the problem here is with the scale-on-export. I know that’s what was recommended during the Blender Twitch stream, but since 2.73, I’ve had problems any time I tried to use scaled output with Blender’s FBX exporter on a skeletal mesh.

I’ve had better luck with treating Blender units as centimeters, making sure scale/rotation/location are applied on both the armature and mesh, and ensuring that the root node has no keyframes on it. I then export at a scale of 1.0 instead of 100.0. Since switching to 1.0 export scale, I’ve had far fewer problems.

Can’t guarantee it’s the problem, but you might want to try scaling up in Blender and applying scale then exporting at 1.0. Generally, I find it’s a good idea to unparent the mesh from the armature, scale both the mesh and the armature by the same amount, apply the scale to both, and then re-parent.

Hope that helps.

finally someone else that knows its easier not to mess with the units:)

there’s no need to unparent as long as you scale the armature up then apply scale to it first and then just apply scale to the mesh and you should have no problems.

Yes,

The scale problem can be solved escaling the mesh and the armature in blender and exporting with scale of 1.0 in the fbx exporter.

What I still need to find is how to solve the twisted bones problem. I will start another thread about this problem in order not to mix it with this one.

You could be right. My Blender->UE4 workflow has developed a bit of paranoia from various problems and a constantly evolving workflow (evolving for the better, though!). I also light incense and sacrifice caffeinated beverages to the Goddess of Successful Imports before exporting.

Those may not be – strictly speaking – completely necessary either. :slight_smile:

You could post a screencap of your export and import settings. Some eagle-eyed person may spot something. I haven’t seen bone roll or orientation problems on models I’ve created in Blender, but I have on those that I’ve imported from FBX and then tried to export back to UE4.

Please report this on the AnswerHub and include a link back to this post and we’ll examine it as a bug -thanks!

Jeff: I have posted my setting on the other thread I started for the twisted bone problem.
You can find it here https://forums.unrealengine.com/showthread.php?57983-Twisted-bones-when-playing-animation-Blender-to-UE4

Steve: I will post on the AnswerHub and link both posts (This one and the twisted bone one).

Hi again Steve,

About the scale issue of mesh/animation. I posted it on the AnswerHub as an answer for an existing question: Blender animation becomes small - UE4 AnswerHub

Thanks for posting this on the AnswerHub. This is being investigated as a bug and any new information regarding a solution from Epic will be added to that post. However, you’re welcome to continue the discussion here in case there’s a solution related more to Blender or the fbx exporter.

The only workaround I’ve had for this issue is to recreate my armature once the scale of my mesh is correct for UE4. If I an existing armature, this scale issue appears when animation is selected in UE4 (even if I apply transforms after scaling).

Yeah, I just spent 5 days trying to narrow down this issue, and I have some workarounds, but no answers as to why this happens.

Firstly, I’m assuming that you’re exporting your FBX’s with the version set to: “FBX 7.4 Binary” correct? That’s the source of the scale discrepancy causing the animation to be a different size than the skeletal mesh. There is no way around it when using the 7.4 Binary (at least, not that I’ve discovered in the 5 days of constant tweaking then exporting and importing… over and over again)

I’ve been using that for my project because of the animation bake settings that it has, but it (for what ever reason) rescales ONLY the animation files and not the skeletal mesh or the skeleton (wtf? am I right?). What makes this more confusing is that everything is perfectly fine when you re-import them back into blender.

To avoid this headache, use the “FBX 6.1 ASCII” version setting. Set “Y forward” and “Z up”
It has it’s own quirks that need to be handled in UE4 on import (like disabling “Convert Scene” in the import dialog box), but at least it doesn’t cause this odd rescaled animation problem we get using other FBX versions.

First off, there’s a line of code in Blender that you need to comment out (I recommend using a second install), that fixes any root bone issues. I’ll try and find the documentation and post a link. Second if you export the UE4 character (from UE4) as an fbx and use that as your template (just open it in Blender without touching it at all) then export it at 100% scaling … in theory that should work. That’s how I do it and I’ve never had an issue with any of the stuff you guys seem to be fighting with.

2.75 (RC1 is out now) has fixed this 100 scale on armatures, have a try, seems to be working for me :slight_smile:

When you import the armature into the unreal engine, just have the scale set to 10 instead of 1. Easy fix >.>