Blender - Armature Not Moving Mesh

Sorry to post about Blender in a UE4 site, but Blender doesn’t seem to have a reliable community forum. I am creating an armature for a character model I made. I parented the mesh to the armature, but nothing happens when I move bones in Pose Mode. Also, the model is completely blue in Weight Paint Mode. Here is a link to my model.

Any help is appreciated.
Thanks in advance!

i would advise

  1. de-parent the mesh
  2. apply/collapase the mirror modifier
  3. weld/join meshs/vertices
  4. re-parent and re-skin/weight

There’s a bunch of things wrong, the armature and mesh are rotated, the mirroring is on the wrong side (you should model the other side instead, but I guess it doesn’t matter since you need to apply it anyway). Remove doubles to merge the center vertices together. There’s scaling done on the mesh in object mode so apply transforms to fix that, enable Deform for the bones in to make sure they can actually deform to mesh. You should probably join the meshes too, and fix the bone parenting. Then parent the mesh to the armature with automatic weights and it should work.

For reliable community forum there is and , you should try there first…

Short version: Your mesh would follow your bones in Blender if your mesh got some armature modifier with a matching bone = vertex-group name and some weights on it.

Long version - you would need:

You need a vertex group with the same name as your bone name.
You need this vertex groups with matching names for every mesh (object) that should follow that bone (body, cloth, hair, …).
You could find the vertex group box if you select your mesh objects (in object mode) and click on the triangle symbol in the properties tab.
You could create a vertex group manually or get a full list of group names if you select your mesh and afterwards your armature and “Set Parent To” → “Armature Deform” “With Automatic Weights” or “With Empty Groups”
If you would not use the Mirror modifier (anymore) but still would use the “X Mirror” option in weightpaint mode (for example if your UVmap is already finished) then make sure your bone/vertex-group-names ends with “L” and “R” like “upperarm_L” and “upperarm_R”.

You could get some weights (more or less working) via automatic weights with the already mentioned parenting “With Automatic Weights”
You could get some weights if you select some faces or vertices in edit mode and click on your “Assign” button in the vertex group box in your properties tab.
You could get some weights if you select the vertex group (or bone) in weight paint mode and paint on your mesh.

If you would do some weight painting then I would recommend to select your armature and switch to the pose mode, select the “human” (armature) symbol in your properties tab and enable “X ray” in the Display pulldown. Afterwards right-click on your mesh in the 3D view (which should select it) and from there switch to weight-paint. That way you could directly right-click your bones in the 3D view of the weight-paint mode (which makes weight-painting a lot easier).

You don’t need the armature as parent but it is handy so I would keep it. It’s not the parent part but the armature modifier that is responsible that your mesh is following your bones in Blender.

Thanks so much for the advice!

Thanks so much for the advice!