Download

Blender, APEX SDK, Morph Targets for clothing.

Hey,

I am currently having a nightmare :(. I am hoping someone with a little more expertise can help me. I am very new to unreal, blender and all of this and I am trying to get morph targets from my character automatically onto my clothing items or make the clothing items automatically move with the character morphs. I have tried many many different ways and non of them are either good solutions or work at all lol. Unfortunately I do not have access to Maya so I am looking for a solution using Blender or the APEX SDK.

I been working on this problem for a very long time and I can’t seem to get past it. Basically most of the time I have been learning unreal. I can’t seem to progress and I am actually stuck.

With the APEX SDK I have found some very interesting results, one was where I imported the character with the hoodie on and loaded the .apx file onto the hoodie material and the character material, then I removed it from the character material and within the previewer, it automatically pushed the hoodie out as I morphed. When closing the previewer it doesn’t work in game lol. Its similar to the video below.

I have made a video showing one of the glitches I found, which does transfer the morph target. It basically transforms the character into the clothing item. Is there a way I can do this in blender or some other software? Transform my character mesh keeping the morph targets on the hoodie? I do imagine there is something that can do this somewhere? Just like I did within unreal… I tried lots and lots of things within blender and nothing will transform my character into the hoodie keeping the morph targets… Maybe taking a portion of the vertices from the character and transforming them into the hoodie? Yes I have tried shrink wrap and the results are terrible. Or maybe even just transfer the morph target to the clothing item. Another possible method which I can’t seem to do, is create templates to snap my clothing to so I can turn that into a shape key within blender?
I can’t believe its sooo difficult :(.

Here is the video I recorded of what I did, sorry about the mic quality I just used a Bluetooth headset I’m tired and my mic is broken :frowning:

https://youtube.com/watch?v=dYqGiETGUf8

I really do hope someone can help me with this cause I am stuck and this is something I need to work :(.
Its so soul destroying when you can’t get past an issue.
Thanks.

Okay here is the 2nd glitch, this is the character Imported with the hoodie on… As you see I load the apx file and add it to clothing, then the body, then remove it from the body and somehow, when I morph the character, the hoodie also morphs.
Its kind of strange how it does that… I can’t really explain what’s going on… Maybe someone can interpret this and it could result in a resolution.

https://youtube.com/watch?v=mtg3OEP8LYI

When i had similar problem, i did a shapekeysetup, similar to the cloths on the character too.
Base should be middlesize on both.
There is a min and max, inbetween it looks nice.
Me have only Blender experience, no apex sdk.

Not really sure what you mean there? Could you show me how you tackled that problem?

I do not use similar stuff now, to show, but i fixed it in my case with help of that.https://youtube.com/watch?v=eskfzfU4NsIcool, in the commentsection is my comment (7 month old) with link to my file ^^

http://orig04.deviantart.net/e78a/f/2015/118/1/7/newpants_by_luftbauch-d8rcybn.png

I hope i miss topic not to far, because i have no apex knowlege.

Hmm, that is a tutorial on how to make clothes for makehuman, how do those pants support morph targets within the unreal engine? Because I have made clothes for makehuman myself, but they don’t morph with my character.

Transferring morph targets to clothing, SORTA… Its not perfect, but it does transfer something… You lose some of the detail if you have complex geometry with like dangle things or pockets that are half open… But it will work for say a T-Shirt.
Here is a video I made of me transferring the morph target, maybe someone with more skills than me can show me how to improve this and get the results I am really looking for… I am soaking in all kinds of information at once here, I have been learning blender, animations, rigging, weight painting, Blueprinting and all sorts… This one task alone has prevented me learning anything for about 3 week now as I have been trying to just combat this problem. It only took me about 2 weeks to learn the previous. I know I have wasted my time, which is what disappoints me… I even spend like 48 hours solid designing morph targets without knowing that I couldn’t use them :frowning:

Here is the video, maybe it will help someone do some other task.
https://youtube.com/watch?v=hUweXf4evQA

I should give this quest up and accept its not possible. Feel like just giving up making a game full stop now.

Thanks.