Download

Blender Animations

So I have a simple character that I made in blender with animations that were also made with blender. I’ve spend 5 hours trying to figure out how to get the animations to work in unreal but I can’t get them to work. Any Help?

Thanks

-how have you made the animation?
-do you get any import errors?
-what happens when you try to import them?
-have you enabled" import animation"? :slight_smile:

  1. I used timeline and keyframes in blender.

  2. Yes I got:
    Warning The following bones are missing from the bind pose:
    Bone.002_end
    Bone.003_L.002_end
    Bone.003_R.002_end
    Bone_L.002_end
    Bone_R.002_end
    This can happen for bones that are not vert weighted. If they are not in the correct orientation after importing,
    please set the “Use T0 as ref pose” option or add them to the bind pose and reimport the skeletal mesh.
    AND:
    Warning Mesh ‘Cube.002’ has no UV set. Creating a default set.
    AND:
    Warning Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

  3. I imports the character with errors but it still imports

  4. Yes

Its important, that you have at frame 0 your T-pose saved.
When not, you have to specify inside ue while import, where it is.
Alt+g alt+t alt+s at frame 0 then insert key at frame 0 with scale / loc / rot.

What is a T-pose?

T-pose is the unposed, pose for the armature/mesh; it’s the pose used before/during rigging so that you can weight paint efficiently.
He’s saying to insert a keyframe at frame 0 in Blender; the problem is that without a starting keyframe for everything, UE4 will read later keyframes as having just created those bones that didn’t have a frame at the start of the animation.

You can also try to uncheck “Add Leaf Bones” in fbx export options. Maybe these bones with “_end” endings are just extra bones added by this option, so they’re not weighted, hence the error… Just a blind guess.

Also make an UV map for your character, otherwise you will get bad results with your lighting/textures.

I undid the Add Leaf Bones checkbox and add a keyframe at frame 0 but the animations still don’t work ( but it did get rid of one error :slight_smile: ) :frowning: I have click on the imported character and went to the animation tab and clicked on the player_anim button in the lower right saved it but it still doesn’t work. Any more help guys?

Good, so this “_end” bones error is gone now?
Try to set export/import options same as in this thread: https://forums.unrealengine.com/showthread.php?62941-Blender-2-73a-and-2-74-working-export-to-UE4-settings-for-various-types
For me, these settings work well every time.

Thank you all I got it working :slight_smile: :slight_smile: