Download

Blender animation problem // floating/moving legs

Hi,

I have a pretty annoying problem with my animations that I made with blender. In blender everything looks correct (the front legs are staying in the right position), but after I have imported them into the UE4, the front legs are “moving” around/going into the floor.

In the UE4:

In blender:

How the rigg looks like:
[SPOILER]goatproblem_frontleg.jpg[/SPOILER]

I have already tried some other import/export settings, blender versions, ue4 version,… but nothing works + I’m not a good animator/I dont have an idea what could be wrong (if it’s a rigg/export/animation problem) :frowning:

Somebody has an idea how I can fix this? :slight_smile:

May be that is a problem with scale or rotation,did you applied rotation and scale in blender before you exported it?

Yep, I have already tried this :frowning:

Hm,
You can try different fbx version, ASCII or Binary.

It just came to my mind that I had a similar problem a “long time ago”,I fixed it by keyframing every bone ( you can do that by pressing A key on your keyboard to select all and then press i key and select loc,rot,scale or something like that) whenever any of the bones had a keyframe on it. I hope I explained it well. :slight_smile:

Thx for the suggestions, but unfortunately still no success :frowning:

mmmm, I think the problem is on the ¨shoulders" of your animal, it seem that the interpretation that it gives on blender and on UE is a little different, maybe try to reparent them?

Also you can setup your animation on UE to play at 0.05 so you can see what is going there on the left panel for animation playback, maybe watching how all the bones move inside UE will guive you some hint.

Have you played with the bake options in the exporter? looks to me like you have animated IK controllers so the animation is not yet backed into the deform bones.

It looks to me like you are not baking all of the the deform bones - I can’t quite tell but it looks like the foot IK is pretty static and perhaps the feet bones are not getting any keys?

Still no success -> a pretty good blender animator is currently searching for the problem, but he also cant find anything :frowning:
Could probably one of you take a look at the rigg/animations? :slight_smile:

Well I will suguest something like #blender on freenode :wink:

I suspect it’s an issue with baking the animation. I don’t think the IK targets translate correctly so you need to bake it.

Try round tripping Blender>FBX>Blender with baked animation and see if you are getting the same behaviour (just to cut any UE factors out of the loop to troubleshoot).

Either bake the animation in blender by running Bake Action with visual keying enabled, or just add IK to your UE4 blueprint.

I think root of the skeleton has animation applied to it. Add another root and leave it on the ground without any animation whatsoever. (or try different settings in regard to root animation, within unreal; during or after import)

Thx for all suggestions. :slight_smile:
I found the problem + fixed it -> it seems like that the UE4 had a problem with the “stretch to constrains” at the back of the animal. I replaced it with bones and now it works