Blender Animation Export To UE4

Hey there, our Problem is Root Motion. Do you have a Root bone? Where have you set your animation keys for the jump? How is the details settings of your animation asset.

First of all I’m not an animator, so probably this question is very noobish, but I would be glad if somebody can help me out here. I downloaded multiple cat animation what I would like to export into the UE4 from blender. If you watch the 2 gifs, you can see the animation is pretty fall apart, it’s not smooth at all. How can I fix this?

Some extra info which might help:
I have others animations like walking and running, and all of them are fine, only the jumping is broken. It seems the issue is the cats paw’s coodinates goes under the ground, but I’m not sure. The other thing which might be related, is that if I switch the root motion lock from Ref pose to anim first frame the cat disappears. Other thing is if I dont enable the root motion or force lock to it, then the cat not visible at all.

This is how it looks in blender:


This is how it looks in UE4:


I’m not sure I’m providing you the correct infos, or not, but I try my best. I’m a programmer so my knowledge ends at the “awsome programmer art level”.


Don’t worry, we’ll figure it out :wink: blender and UE is sometimes…meh…but I’ve seen the next days there will be a Stream from EPIC.
Anyway, would you share your blendfile? Then I could have a look. Maybe it’s something with the export settings, but it’s hard to guess. Does it make a difference what you see in the animation editor viewport and in an actual level?

This is not a “free” download, and the original creator does not allow me to upload it here. Actually I was contacted with him, but he does not know the UE stuff. Maybe if you can provide me an email, I can send it to you.

There is no difference between the level and the viewport.
I attached the exportsettings, but honestly I tried every possible combination in the last 2 days.





Actually I think I solved the issue somewhat, its much smoother now, but its still locked in place, but I assume its normal, because if I lock the root bone to the origin then the capsule doesnt want to follow the mesh. Now I have to find out, how can I calculate the jump curve to syncronize with the animation. Do you know some good sollution to this, or I need just do lot of maths? And the other thing what I dont know is why the original UE4 animations are good without root motion?

This looks like much better now:


normally the jump of the capsule should also be come by your root motion and you should not need to struggle with that. thats the whole idea behind root motion, to get the capsuel controlled by the animation itself. in the animation editor in the down arrow there is in some submenu an option to process root motion in the animation editor or not - have a look at this (sorry not on the computer right now, can’t make you a screenshot or give more details)

I was trying to find out what do you mean by " process root motion in the animation editor or not", but I wasnt able to find anything like “process root motion” in the animation editor. I assume I’m opened the “animation editor”.

Also in the Menu character->bones-> use “All hirarchy” to see whats going on