Blender animation - Bone rotations

I’m having some trouble getting an animation properly into UE4. Everything in the animation looks as it should, except for two bones, which get some weird rotations during part of the animation in UE4. On the Blender side everything ooks ok. Scaling and rotation are all set to 1 and 0.

Gif of the problem in Unreal: Dropbox - File Deleted

I tried several things but nothing seemed to have an effect. Also tried to give the affected parts minimal rotations but nothing helped.
Anyone had similar issues or know a fix to that?
Thanks already!

Hard to say what’s going on here from just this information.

The first thought I have is that the bone that controls the kneecaps has something odd that UE4 is interpreting differently than Blender. I’ve seen similar things happen when I had previously rotated a bone on an axis 360° (which is visually identical to 0°), and then later tried to interpolate from 360° instead of from 0°.

The best way to debug is probably to pull up the dope sheet / action editor in Blender, and take a look at the keyframes for the bones that aren’t behaving, and see if there’s anything odd about the rotation or roll of those bones.

Another option is that the animation baking that happens on export is doing something funky. You could try manually baking the action and looking at the resulting animation to see if the same behavior shows up. If it does, you could then fix the baked animation and export that instead.

Worst case scenario, delete the keyframes from the troublesome bones, see if that fixes, and then re-animate just those bones if it does.

Think I’ve figured it out. It was Blender’s fbx exporter that messed up, wasn’t UE4. I looked into every keyframe for those two bones, some of them had negative rotations, after I set them to slightly different positive values each time it exportet correctly.