Download

Blender 2.8 to UE4 4.25 Light Leaks In Building.

No matter what I try, no matter What Guide I follow, No matter How many times I remake the model from scratch, The light just keeps on leaking even though the model is “Water Tight” Everything is merged/Joined where needed, The model has no double edges or verts its literally as solid as I can possibly make it… The texture Inside UE4 has been tested as normal and two-sided nothing seems to matter… I have tried creating my own light maps multiple times with different margins and I’ve tried using UE4’s auto created Light maps… Same stuff… Its driving me mental to the point I want to throw my pc through the window. I’ve been non stop testing this poop for 3 days solid and NOTHING changes… Does anybody know whats going on? Below are some images and I will also share the blender file itself… if anybody can see the issue could you please let me know maybe even do a video to show what i’ve missed?

Blender 2.8 Model File

Light Leaking In Blender 2.8
LightLeak_Dropper_Blender.jpg

Light Leaking in UE4 4.25
LightLeak_Dropper_UE4.png

Do any faces extend beyond each other in the corners? If a surface is visible on the outside then it can receive light and the pixels of the lightmap won’t line up exactly where the two pieces intersect so the light will be visible inside.

Otherwise, it can be useful to have an outside facing wall to block light even if that outside wall isn’t going to be visible, just use a low-resolution lightmap for it since it just needs to block light.

Hi!

I could only import the fbx file…
Your whole mesh is made out of planes: it needs to be 3D!! Walls with thickness!
The other thing is the mesh is way too big to achieve proper (static) lighting result! You’ll need to break it up into smaller pieces and then you can assign a high enough lightmap resolution!

I don’t believe this to be correct, I’ve seen dev’s create entire environments using just planes and they don’t have the light leaking issues… There are so many videos online of people just using planes and their stuff doesn’t have the light leak issue either. I have also made an entire new model as you say 3d… and it still does the same thing… Light leaking through… So its not the fact I’m using planes as it still does it with thick walls… Everything is connected correctly all corners are merged and the object would literally be water tight… No gaps anywhere.

Nope all corners are merged as one which makes the entire model “Water Tight” There shouldn’t be any light leaking in but for some reason its just leaks the light inside… I’ve rebuilt the model 3 times, I’ve tried planes and thick walls and tried modeling a version with no cuts and kept it all as one piece yet the light still leaks in which should be impossible…

I might go ahead and add a box around the entire model and see if that will cut the light leaks out but in reality that shouldn’t be needed basically its going to be adding 6 faces to my model that I shouldn’t even need to be doing and I don’t think that’s the correct way to be doing it.

One other thing I’ve noticed… If i Drag the model straight into the world its dark inside (Which Is what I want) But if I put the model in a blueprint and put the blueprint in the world its light inside like full day time… Why is this?

Try enabling double-sided shadowing (Or two-sided shadowing, can not remember what it is off the top of my head) on the mesh and see if that helps get rid of the issue.

As Makigirl has stated, your walls need thickness. I added a simple Solidify Modifier in Blender to show example.

I’ve encountered the issue before without ray tracing, and I thought it could have something to do with the volumetric lightmap and its settings. Are the directional and skylight each static / stationary / movable? Is there also a Light Propagation Volume enabled (not merely in the Show flag, but for the project)? To check, go to the ConsoleVariables.ini file and look for r.LightPropagationVolume = 1. It’s set at 0, then it’s disabled. It has similar artifacts when placed over the scene…though if it’s following the camera and is at default settings, then it’s obviously not the LPV.

have you tried enabling high precision UVs for the mesh?
Have you tried increasing the lightmap resolution?
Also, you seem to be talking about baked lighting (lightmaps and all that) but that screenshot looks like its dynamic lighting. Are you sure mobility is set to static on both the lightsource and the meshes?