Download

Blender 2.78 to UE4 4.14 import/export issue

Hi,

I found a really great video (“Unreal Engine 4 Support Twitch Broadcast: Blender and UE4”) in which Kevin Vassey demonstrates how to import/export FBX files between UE4 and Blender. However, the versions of the apps he used are a bit older and it seems that many of the settings have changed.

Through lots of experimenting, I was able to come up with some new settings that “almost” work. But I could really use some help on the last leg. :slight_smile: When I apply an animation, it looks like some of the bones aren’t working properly. It looks like this:

problem1.png

In a nutshell, I am able to export the SK_Mannequin skeletal mesh as an FBX via “Asset Actions > Export” from UE4, and then import it into Blender using the following settings:

import1.png
import2.png

I’m not an animator/modeler, but it seems like the skeleton is relatively uniform:

blender_front.png
47fd293e0d0f0744bd4ba2097977b7791ec60867.png

Next, I export the whole scene (“select object only” doesn’t seem to work anymore) using the following settings:

export1.png
export2.png
export3.png
export4.png

I then import the newly created FBX back into UE4 using the default settings:

1a20980d7e9b5bd4ba999b34061807f5782eb38d.png

It looks like the scaling is good and all the limbs are attached:

scale.png

I then re-target a running animation to the new skeleton via “Right-click on animation > Retarget Anim Assets > Duplicate Anim Assets and Retarget” and use the following options:

retarget.png

Here are some more screenshots of some of the actual bones that might be involved:

problem2.png
problem3.png
problem4.png
problem5.png
problem7.png
problem8.png
c316c3f8f19f46ab539a1d84da73397d9b523254.png
problem8.png
problem11.png
problem6.png

I hope this helps illustrate the issue I’m encountering. (Picture says a thousand words…or maybe a thousand pictures say something? :wink:
Any help or suggestions would be greatly appreciated!

Thanks!

Ok, I think I figured it out:

First, in the animation view’s skeleton tree section, turn on “Show Retargeting Options”:

show_retargeting_options.png

Next, select the naughty bone in the tree, right click, and choose “Recusively Set Translation Retargeting Skeleton”:

recursive.png

And it’s fixed!

fixed.png

Glad your issue is solved! Thank you for sharing your solution, I’m sure others with similar issues will appreciate it.