Download

Blender 2.76 FBX exporting

Hello,

I’m currently running UE4.9 on Linux Mint. I’ve been trying to figure out why I can’t get FBX textures to import. I recently updated from UE4.8 (and an older version of Blender), and I’m starting to think there’s a regression or something that’s messing with this.

Basically, I followed the process outlined in the UE4 wiki on exporting FBX files from Blender to UE4 (creating the light map UV’s, traingulating the mesh, scaling up, etc.) using a simple cube at the world’s origin. When I tried importing it into UE4, I get the message saying the import failed and consequently, the asset wasn’t created.

Here’s the dump from my console:


[2015.11.12-14.00.32:694][857]LogDirectoryWatcher:Error: inotify_add_watch cannot watch folder /home/joel/Projects/bethel_model/test_export.fbx/ (errno = 20, Not a directory)
[2015.11.12-14.00.42:798][857]LogFactory: FactoryCreateBinary: StaticMesh with ReimportFbxStaticMeshFactory (0 0 /home/joel/Projects/bethel_model/test_export.fbx)
[2015.11.12-14.00.42:803][857]LogFbx: ItemName: GlobalSettings, ItemCount : 1
[2015.11.12-14.00.42:810][857]LogFbx: Loading FBX Scene from /home/joel/Projects/bethel_model/test_export.fbx
[2015.11.12-14.00.42:816][857]LogFbx: FBX Scene Loaded Succesfully
[2015.11.12-14.00.54:959][857]LogFbx: Loading FBX Scene from /home/joel/Projects/bethel_model/test_export.fbx
[2015.11.12-14.00.54:964][857]LogFbx: FBX Scene Loaded Succesfully
[2015.11.12-14.00.54:966][857]FBXImport:Error: Error Import failed. 
[2015.11.12-14.01.00:540][857]LogAssetTools:Warning: Failed to import '/home/joel/Projects/bethel_model/test_export.fbx'. Failed to create asset '/Game/VehicleAdvBP/test_export'

Other than an inotify issue at the start (no idea why it’s trying to put a watch on a file it’s importing), there’s nothing in the console output to suggest an error.

What makes me think it’s a regression of some sort is that I can bring in static meshes that I’ve exported previously (a couple of months ago) without issue.

Any thoughts on how I might be able to track down this nebulous error?

I don’t suppose anyone can tell me if the FBX 2014 specification is the same as FBX 7.4? I assume they’re not, and it may be the source of my problem, as the FBX export script bundled with Blender 2.76 only supports 7.4 (binary) and 6.1 (ASCII)

Is 2.76 ready for the penguin?
I would ask that inside the Blenderforum
But…" /test_export.fbx/ (errno = 20, Not a directory)" the slash behind fbx, means that not he is calling it as folder not a file?
Named you a folder ***.fbx?

[SOLVED] Blender 2.76 FBX exporting

Turns out it’s my .blend file. Looks like there’s something in it that’s corrupting the FBX export. I’ve no idea what that is, so I guess I’ll start a new file and do my exporting out of that.